Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-2715

Upgrade Thrift dependency to 0.9.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0, 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: Metastore
    • Labels:
      None

      Description

      I work on HCatalog (0.2). Recently, we ran into HCat_server running out of memory every few days, and it boiled down to a bug in thrift, (THRIFT-1468, recently fixed).

      HCat-0.2-branch depends on Hive-0.8, which in turn depends on thrift-0.5.0. (The bug also exists on 0.7.0.)

      May I please enquire if Hive can't depend on a more current version of thrift? (Does it break the metastore?) I'm afraid I'm not privy to the reasoning behind Hive's dependency on a slightly dated thrift-lib.

        Attachments

        1. hive-2715.patch
          3.57 MB
          Ashutosh Chauhan
        2. hive-2715_2.patch
          4.19 MB
          Ashutosh Chauhan

          Issue Links

            Activity

              People

              • Assignee:
                ashutoshc Ashutosh Chauhan
                Reporter:
                mithun Mithun Radhakrishnan
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: