Hive
  1. Hive
  2. HIVE-2701

listPartitionsByFilter only supports non-string partitions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      listPartitionsByFilter supports only non-string partitions. This is because its explicitly specified in generateJDOFilterOverPartitions in ExpressionTree.java.

      //Can only support partitions whose types are string
      if( ! table.getPartitionKeys().get(partitionColumnIndex).
      getType().equals(org.apache.hadoop.hive.serde.Constants.STRING_TYPE_NAME) )

      { throw new MetaException ("Filtering is supported only on partition keys of type string"); }

        Activity

        Aniket Mokashi created issue -
        Aniket Mokashi added a comment -

        Possibly a browser bug! I will close this ticket as duplicate of 2702.

        Aniket Mokashi made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4m 37s 1 Aniket Mokashi 10/Jan/12 07:22

          People

          • Assignee:
            Unassigned
            Reporter:
            Aniket Mokashi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development