Hive
  1. Hive
  2. HIVE-2687

Test classpath should resemble runtime classpath

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.8.0
    • Fix Version/s: None
    • Component/s: Testing Infrastructure
    • Labels:
      None

      Activity

      Carl Steinbach added a comment -

      The scripts in the bin/ directory execute Hive using the
      'hadoop jar' command. Consequently Hive inherits and gives
      precedence to the contents of Hadoop's lib/ directory. We
      need to make sure that Hive tests run with a similar
      classpath.

      Carl Steinbach added a comment -

      Duplicate of HIVE-2646.


        People

        • Assignee:
          Unassigned
          Reporter:
          Carl Steinbach
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development