Hive
  1. Hive
  2. HIVE-2618

Describe partition returns table columns but should return partition columns

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      If a partitioned table and some partitions are created, and then the table is altered adding a columns, if describe is called on the partitions created before the columns were added it will show the new columns, even though it should not. In particular, in the metastore, the partition will not have these columns.

        Activity

        Namit Jain added a comment -
        He Yongqiang added a comment -

        +1, running tests.

        He Yongqiang added a comment -

        already committed, thanks namit!

        Carl Steinbach added a comment -

        Looks like this patch was included in the fix for HIVE-1003. Resolving as a duplicate.

        Carl Steinbach added a comment -

        Turns out this is not a duplicate of HIVE-1003. The commit message for the patch accidentally referenced HIVE-1003:

        5c60e89 2011-12-08 HIVE-1003 [jira] optimize metadata only queries (Namit Jain via Yongqiang He)
        c0bbc1f 2011-10-31 HIVE-1003: optimize metadata only queries (Marcin Kurczych, Namit Jain via He Yongqiang)
        

          People

          • Assignee:
            Namit Jain
            Reporter:
            Kevin Wilfong
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development