Hive
  1. Hive
  2. HIVE-2591

Hive 0.7.1 fails with "Exception in thread "main" java.lang.NoSuchFieldError: type"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 0.7.1
    • Fix Version/s: None
    • Component/s: CLI, JDBC, SQL
    • Labels:
    • Environment:

      Intel Core2 Quad CPU Q8400 @2.66GHz
      4 GB RAM
      Ubuntu 10.10 32 bit
      JDK 6.0_27
      Apache Ant 1.8.0
      Apache Hive 0.7.1
      Apache Hadoop 0.20.203.0

    • Tags:
      Hive

      Description

      Hi,

      When I try to invoke hive and type in "SHOW TABLES" in cli in the environment as explained above, I get "Exception in thread "main" java.lang.NoSuchFieldError: type" and I am not able to use it at all.

      Is there any temporary fix for this? Please let me know, if I am making any mistake here.
      I have downloaded Hive 0.7.1 from the download link as mentioned in the Hive Wiki. The download url is http://hive.apache.org/releases.html.

      /opt/hive-0.7.1$ hive
      WARNING: org.apache.hadoop.metrics.jvm.EventCounter is deprecated. Please use org.apache.hadoop.log.metrics.EventCounter in all the log4j.properties files.
      Hive history file=/tmp/hadoop/hive_job_log_hduser_201111190121_764439225.txt
      hive> SHOW TABLES;
      Exception in thread "main" java.lang.NoSuchFieldError: type
      at org.apache.hadoop.hive.ql.parse.HiveLexer.mKW_SHOW(HiveLexer.java:1234)
      at org.apache.hadoop.hive.ql.parse.HiveLexer.mTokens(HiveLexer.java:5942)
      at org.antlr.runtime.Lexer.nextToken(Lexer.java:89)
      at org.antlr.runtime.BufferedTokenStream.fetch(BufferedTokenStream.java:133)
      at org.antlr.runtime.BufferedTokenStream.sync(BufferedTokenStream.java:127)
      at org.antlr.runtime.CommonTokenStream.setup(CommonTokenStream.java:127)
      at org.antlr.runtime.CommonTokenStream.LT(CommonTokenStream.java:91)
      at org.apache.hadoop.hive.ql.parse.HiveParser.statement(HiveParser.java:521)
      at org.apache.hadoop.hive.ql.parse.ParseDriver.parse(ParseDriver.java:436)
      at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:327)
      at org.apache.hadoop.hive.ql.Driver.run(Driver.java:736)
      at org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:164)
      at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:241)
      at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:456)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.hadoop.util.RunJar.main(RunJar.java:156)

      I am not sure what is the actual issue here or rather how to fix it.
      Can you please let me know if there is any workaround for this.

      Alternatively I tried building hive from the SVN source repo.
      I am neither able to build hive from SVN. I get the following error.
      [datanucleusenhancer] >> D:\hive\build\ivy\lib\default\zookeeper-3.3.1.jar
      [datanucleusenhancer] Exception in thread "main" java.lang.VerifyError: Expecting a stackmap frame at branch target 76 in method org.apache.hadoop.hive.metastore.model.MDatabase.jdoCopyField(Lorg/apache/hadoop/hive/metastore/model/MDatabase;I)V at offset 1
      [datanucleusenhancer] at java.lang.Class.getDeclaredFields0(Native Method)
      [datanucleusenhancer] at java.lang.Class.privateGetDeclaredFields(Class.java:2308)
      [datanucleusenhancer] at java.lang.Class.getDeclaredFields(Class.java:1760)
      [datanucleusenhancer] at org.datanucleus.metadata.ClassMetaData.addMetaDataForMembersNotInMetaData(ClassMetaData.java:358)
      [datanucleusenhancer] at org.datanucleus.metadata.ClassMetaData.populate(ClassMetaData.java:199)
      [datanucleusenhancer] at org.datanucleus.metadata.MetaDataManager$1.run(MetaDataManager.java:2394)
      [datanucleusenhancer] at java.security.AccessController.doPrivileged(Native Method)
      [datanucleusenhancer] at org.datanucleus.metadata.MetaDataManager.populateAbstractClassMetaData(MetaDataManager.java:2388)
      [datanucleusenhancer] at org.datanucleus.metadata.MetaDataManager.populateFileMetaData(MetaDataManager.java:2225)
      [datanucleusenhancer] at org.datanucleus.metadata.MetaDataManager.initialiseFileMetaDataForUse(MetaDataManager.java:925)
      [datanucleusenhancer] at org.datanucleus.metadata.MetaDataManager.loadMetadataFiles(MetaDataManager.java:399)
      [datanucleusenhancer] at org.datanucleus.enhancer.DataNucleusEnhancer.getFileMetadataForInput(DataNucleusEnhancer.java:806)
      [datanucleusenhancer] at org.datanucleus.enhancer.DataNucleusEnhancer.enhance(DataNucleusEnhancer.java:582)
      [datanucleusenhancer] at org.datanucleus.enhancer.DataNucleusEnhancer.main(DataNucleusEnhancer.java:1316)

      BUILD FAILED
      D:\Projs_Source\hive\build.xml:297: The following error occurred while executing this line:
      D:\Projs_Source\hive\build.xml:154: The following error occurred while executing this line:
      D:\Projs_Source\hive\metastore\build.xml:98: Java returned: 1

      Total time: 32 seconds

      Any inputs to fix these issues will be very helpful.

      Thanks,
      Prashanth.

        Activity

        Prashanth created issue -
        Carl Steinbach made changes -
        Field Original Value New Value
        Fix Version/s 0.8.0 [ 12316178 ]
        Fix Version/s 0.7.1 [ 12316336 ]
        Andy Jefferson added a comment -

        > java.lang.VerifyError: Expecting a stackmap frame at branch target 76 in method

        Means you are using JDK1.7 and the DataNucleus enhancer uses ASM3.x (JDK1.6 java bytecode). You can use the tip at the end of this post
        http://www.datanucleus.org/servlet/forum/viewthread_thread,6799_lastpage,yes#lastpost
        to use JDK1.7 with current DataNucleus

        ransom.hezhiqiang added a comment -

        you should use jdk 1.6
        because jdk1.7 jdbc interface has some change.
        i have them same VerifyError when build hive.
        after change jdk.it was success.

        ransom.hezhiqiang added a comment -

        type error:
        it looks some problems in antlr. is the hive.g files changed?

        Roshan Pradeep added a comment -

        Hi

        I am also getting this "type error". Haven't modify any files and just download and configure the following pieces.

        Hadoop - 1.0.1
        Hive - 0.81

        Any help is appreciated.

        Edward Capriolo added a comment -

        The problem is being compiled against one version of antlr and running with anouther. Does hadoop 1.0 have an antlr on the classpath?

        Edward Capriolo made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Prashanth
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development