Hive
  1. Hive
  2. HIVE-2570

ShimLoader does not work with Hadoop 0.20.20#.0 because of nano version.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Invalid
    • Affects Version/s: 0.7.1, 0.9.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The ShimsLoader getMajorVersion() method expects a version is #.#.# (2 dots only) but the Hadoop security releases are #.#.#.# (ie 0.20.205.0)

        Activity

        Hide
        Alejandro Abdelnur added a comment -

        My bad, read the code wrong.

        Show
        Alejandro Abdelnur added a comment - My bad, read the code wrong.

          People

          • Assignee:
            Unassigned
            Reporter:
            Alejandro Abdelnur
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development