Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-24480

Remove metastore upgrade script from 3.1.3000 to 4.0.0

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Testing Infrastructure
    • Labels:
      None

      Description

      HIVE-23965 relies on a dockerized metastore that is on a internal metastore version (3.1.3000) so to be usable in master there needs to be an upgrade script bringing it to 4.0.0. 

      Although this script is only used by tests it should be nice to remove it in order to avoid maintaining two files on every change in the schema of the metastore.

      One possible way to do this would be to bring the dockerized metastore  to a standard Apache version (for instance 3.2.0). 

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                zabetak Stamatis Zampetakis
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: