Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-23535

Bump Minimum Required Version of Maven to 3.0.5

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.0
    • Component/s: None
    • Labels:
      None

      Description

      pom.xml
        <prerequisites>
          <maven>2.2.1</maven>
        </prerequisites>
      

      Time to upgrade to 3.x

      In Maven 3, use Maven Enforcer Plugin's requireMavenVersion rule, or other rules to check other aspects.

      https://maven.apache.org/pom.html#prerequisites

       

      We get the Enforcer Plugin from the Apache Parent POM.

        Attachments

        1. HIVE-23535.1.patch
          0.3 kB
          David Mollitor

          Activity

            People

            • Assignee:
              belugabehr David Mollitor
              Reporter:
              belugabehr David Mollitor
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: