Hive
  1. Hive
  2. HIVE-2294

Allow ShimLoader to work with Hadoop 0.20-append

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Not a Problem
    • Affects Version/s: 0.7.1
    • Fix Version/s: 0.8.0
    • Component/s: None
    • Labels:
      None

      Description

      If we are running Hive with Hadoop 0.20-append, Hive ShimLoader does not get Hadoop version correctly. Suffix starts with '-' should be removed from major version info.

      1. HIVE-2294.1.patch
        1 kB
        YoungWoo Kim
      2. HIVE-2294.2.patch
        0.6 kB
        YoungWoo Kim
      3. HIVE-2294.3.patch
        0.6 kB
        YoungWoo Kim

        Activity

        YoungWoo Kim added a comment -

        My bad. I checked again but could not reproduce the problem with hadoop-0.20 branch. This might be my classpath problem. I'll reopen this issue if I reproduce the problem correctly.

        Amareshwari Sriramadasu added a comment -

        I see the version on branch-0.20-append is fine. It is 0.20.3-SNAPSHOT from the branch.
        [amarsri@xxx branch-0.20-append]$ bin/hadoop version
        Hadoop 0.20.3-SNAPSHOT
        Subversion https://svn.apache.org/repos/asf/hadoop/common/branches/branch-0.20-append -r 1057313
        Compiled by amarsri on Mon Aug 1 16:09:04 IST 2011

        What problem are you facing with this branch?

        YoungWoo Kim added a comment -

        Fix typo and re-create a patch

        John Sichi added a comment -

        Typo: surfix -> suffix

        YoungWoo Kim added a comment -

        Re-create a patch from svn

        YoungWoo Kim added a comment -

        Patch for HIVE-2294


          People

          • Assignee:
            YoungWoo Kim
            Reporter:
            YoungWoo Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development