Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-22344

I can't run hive in command line

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: CLI
    • Labels:
      None
    • Environment:

      hive: 3.1.2

      hadoop 3.2.1

       

      Description

      I can't run hive in command. It tell me :

      [hadoop@master lib]$ hive
      which: no hbase in (/home/hadoop/apache-hive-3.1.2-bin/bin:{{pwd}}/bin:/home/hadoop/.local/bin:/home/hadoop/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin)
      SLF4J: Class path contains multiple SLF4J bindings.
      SLF4J: Found binding in [jar:file:/home/hadoop/apache-hive-3.1.2-bin/lib/log4j-slf4j-impl-2.10.0.jar!/org/slf4j/impl/StaticLoggerBinder.class]
      SLF4J: Found binding in [jar:file:/home/hadoop/hadoop3/share/hadoop/common/lib/slf4j-log4j12-1.7.25.jar!/org/slf4j/impl/StaticLoggerBinder.class]
      SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
      SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory]
      Exception in thread "main" java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkArgument(ZLjava/lang/String;Ljava/lang/Object;)V
              at org.apache.hadoop.conf.Configuration.set(Configuration.java:1357)
              at org.apache.hadoop.conf.Configuration.set(Configuration.java:1338)
              at org.apache.hadoop.mapred.JobConf.setJar(JobConf.java:536)
              at org.apache.hadoop.mapred.JobConf.setJarByClass(JobConf.java:554)
              at org.apache.hadoop.mapred.JobConf.<init>(JobConf.java:448)
              at org.apache.hadoop.hive.conf.HiveConf.initialize(HiveConf.java:5141)
              at org.apache.hadoop.hive.conf.HiveConf.<init>(HiveConf.java:5099)
              at org.apache.hadoop.hive.common.LogUtils.initHiveLog4jCommon(LogUtils.java:97)
              at org.apache.hadoop.hive.common.LogUtils.initHiveLog4j(LogUtils.java:81)
              at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:699)
              at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:683)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:498)
              at org.apache.hadoop.util.RunJar.run(RunJar.java:323)
              at org.apache.hadoop.util.RunJar.main(RunJar.java:236)
      

      I don't know what's wrong about it.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              d87904488 Smith Cruise
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated: