Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-20659

Update commons-compress to 1.18 due to security issues

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.2.1, 2.3.2, 3.1.0, 3.0.0
    • Fix Version/s: 4.0.0
    • Component/s: Hive
    • Labels:
      None

      Description

      Currently most Hive version depends on commons-compress 1.9 or 1.4. Those versions have several security issues: https://commons.apache.org/proper/commons-compress/security-reports.html

      I propose to upgrade all commons-compress dependencies in all Hive (sub-)projects to at least 1.18. This will also make it easier for future extensions to Hive (serde, udfs, etc.) that have dependencies to commons-compress (e.g. https://github.com/zuinnote/hadoopoffice/wiki) to integrate into Hive without upgrading the commons-compress library manually in the Hive lib folder.

        Attachments

        1. HIVE-20659.1.patch
          0.8 kB
          Bharath Krishna

          Issue Links

            Activity

              People

              • Assignee:
                bharos92 Bharath Krishna
                Reporter:
                jornfranke Jörn Franke
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: