Hive
  1. Hive
  2. HIVE-2061

Create a hive_contrib.jar symlink to hive-contrib-{version}.jar for backward compatibility

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.8.0
    • Component/s: Build Infrastructure
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      We have seen a use case where in the user's script, it run 'add jar hive_contrib.jar'. Since Hive has moved the jar file to be hive-contrib-

      {version}

      .jar, it introduced backward incompatibility. If we as the user to change the script and when Hive upgrade version again, the user need to change the script again. Creating a symlink seems to be the best solution.

      1. HIVE-2061.patch
        0.8 kB
        Ning Zhang

        Activity

        Hide
        Paul Yang added a comment -

        Looks good, will test and commit.

        Show
        Paul Yang added a comment - Looks good, will test and commit.
        Hide
        Paul Yang added a comment -

        Committed. Thanks Ning!

        Show
        Paul Yang added a comment - Committed. Thanks Ning!
        Hide
        Carl Steinbach added a comment -

        Committed to trunk.

        Show
        Carl Steinbach added a comment - Committed to trunk.

          People

          • Assignee:
            Ning Zhang
            Reporter:
            Ning Zhang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development