Hive
  1. Hive
  2. HIVE-1987

HWI admin_list_jobs JSP page throws exception

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0, 0.7.1
    • Fix Version/s: 0.8.0
    • Component/s: Web UI
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      It looks like the admin_list_jobs.jsp page is trying to reference ExecDriver.runningJobKillURIs, which is now a private to ExecDriver:

      
      RequestURI=/hwi/admin_list_jobs.jsp
      
      Caused by:
      
      org.apache.jasper.JasperException: Unable to compile class for JSP
      
      An error occurred at line: 24 in the jsp file: /admin_list_jobs.jsp
      Generated servlet error:
      The field ExecDriver.runningJobKillURIs is not visible
      
      An error occurred at line: 27 in the jsp file: /admin_list_jobs.jsp
      Generated servlet error:
      The field ExecDriver.runningJobKillURIs is not visible
      
      
      	at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:84)
      	at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:328)
      	at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:409)
      	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:288)
      	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:267)
      	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:255)
      	at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:563)
      	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:293)
      	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
      	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:502)
      	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:363)
      	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
      	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
      	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      	at org.mortbay.jetty.handler.RequestLogHandler.handle(RequestLogHandler.java:49)
      	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      	at org.mortbay.jetty.Server.handle(Server.java:324)
      	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
      	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:864)
      	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:533)
      	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:207)
      	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:403)
      	at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)
      	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:522)
      

        Activity

        Carl Steinbach added a comment -

        Looks like this was broken by HIVE-1408 which was committed back in July.

        @Ed: Is there any way to test JSP pages?

        Edward Capriolo added a comment -

        We have two tickets open. One to precompile the pages, one to move to wikit which would move 99% of the code to servlets. I am a big fan of moving all this to wikit for 0.8.0. This page is not critical to the operation of the Web Interface. We can just remove the page (since you can figure the info out from the JobTracker page) or change the signature back to public if possible. Let me know what you want to do.

        Carl Steinbach added a comment -

        @Ed: I like option 1 (removing the page). Changing the signature back to public doesn't seem ok to me.

        Alex Newman added a comment -

        Any resolution here?

        Carl Steinbach added a comment -

        Committed to trunk. Thanks Ed!

        Hudson added a comment -

        Integrated in Hive-trunk-h0.21 #904 (See https://builds.apache.org/job/Hive-trunk-h0.21/904/)
        HIVE-1987. HWI admin_list_jobs JSP page throws exception (Edward Capriolo via cws)

        cws : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1159443
        Files :

        • /hive/trunk/hwi/web/admin_list_jobs.jsp
        • /hive/trunk/hwi/web/left_navigation.jsp

          People

          • Assignee:
            Edward Capriolo
            Reporter:
            Carl Steinbach
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development