Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      It broken on the current trunk:

      $ ant test -Dtestcase=TestHBaseCliDriver
      ....
      ....

      test:
      [junit] Running org.apache.hadoop.hive.cli.TestHBaseCliDriver
      [junit] Exception: Timed out trying to locate root region
      [junit] org.apache.hadoop.hbase.client.NoServerForRegionException: Timed out trying to locate root region
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRootRegion(HConnectionManager.java:976)
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:625)
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.relocateRegion(HConnectionManager.java:607)
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:738)
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:634)
      [junit] at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:601)
      [junit] at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:128)
      [junit] at org.apache.hadoop.hive.hbase.HBaseTestSetup.setUpFixtures(HBaseTestSetup.java:87)
      [junit] at org.apache.hadoop.hive.hbase.HBaseTestSetup.preTest(HBaseTestSetup.java:59)
      [junit] at org.apache.hadoop.hive.hbase.HBaseQTestUtil.<init>(HBaseQTestUtil.java:31)
      [junit] at org.apache.hadoop.hive.cli.TestHBaseCliDriver.setUp(TestHBaseCliDriver.java:43)
      [junit] at junit.framework.TestCase.runBare(TestCase.java:125)
      [junit] at junit.framework.TestResult$1.protect(TestResult.java:106)
      [junit] at junit.framework.TestResult.runProtected(TestResult.java:124)
      [junit] at junit.framework.TestResult.run(TestResult.java:109)
      [junit] at junit.framework.TestCase.run(TestCase.java:118)
      [junit] at junit.framework.TestSuite.runTest(TestSuite.java:208)
      [junit] at junit.framework.TestSuite.run(TestSuite.java:203)
      [junit] at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      [junit] at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      [junit] at junit.framework.TestResult.runProtected(TestResult.java:124)
      [junit] at junit.extensions.TestSetup.run(TestSetup.java:23)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:422)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:931)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:785)
      [junit] Hive history file=/data/users/nzhang/work/2/apache-hive/build/hbase-handler/tmp/hive_job_log_nzhang_20110

        Issue Links

          Activity

          Ning Zhang created issue -
          Ning Zhang added a comment -

          John, can you please take a look?

          Ning Zhang made changes -
          Field Original Value New Value
          Assignee John Sichi [ jvs ]
          John Sichi added a comment -

          Dupe of HIVE-1716. It's a sporadic issue, probably due to a port lingering. I'll see if I can add a sleep somewhere to squelch it.

          John Sichi made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          John Sichi made changes -
          Link This issue duplicates HIVE-1716 [ HIVE-1716 ]
          Ning Zhang added a comment -

          oops, I forgot I filed a JIRA for the same problem. It's now failing more often (3 times in a row).

          John Sichi added a comment -

          Yeah, it seems to have gotten much worse since the concurrency patch with zookeeper got committed, so it may be some interference between the different instances of zookeeper.

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          14m 37s 1 John Sichi 13/Jan/11 18:57

            People

            • Assignee:
              John Sichi
              Reporter:
              Ning Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development