Hive
  1. Hive
  2. HIVE-1877

Add java_method() as a synonym for the reflect() UDF

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.9.0
    • Component/s: UDF
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      java_method() is a synonym for reflect()

      Description

      HIVE-471 added the reflect() UDF which allows people to invoke static Java methods from within HQL
      queries. In my opinion the name is confusing since it describes how the UDF works instead of what
      it does. I propose changing the name of (or providing a synonym for) the UDF to something like
      'invoke_method' or 'java_method', or something similar. I'm open to suggestions.

      1. HIVE-1877.3.patch.txt
        10 kB
        Zhenxiao Luo
      2. HIVE-1877.2.patch.txt
        12 kB
        Carl Steinbach
      3. HIVE-1877.1.patch.txt
        11 kB
        Carl Steinbach

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Zhenxiao Luo
              Reporter:
              Carl Steinbach
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development