Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-18612

Build subprocesses under Yetus in Ptest use 1.7 jre instead of 1.8

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: Testing Infrastructure
    • Labels:
      None

      Description

      As per this jira comment made by Yetus maven plugins that want to use java executable are seeing a 1.7 java binary. In this particular case Yetus sets JAVA_HOME to a 1.8 JDK installation, and thus maven uses that, but any subsequent java executes will use the JRE which they see on PATH.

      This should be fixed by adding the proper java/bin (that of JAVA_HOME setting) to PATH.

        Attachments

        1. HIVE-18612.0.patch
          0.7 kB
          Ádám Szita

          Activity

            People

            • Assignee:
              szita Ádám Szita
              Reporter:
              szita Ádám Szita
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: