Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-18112

show create for view having special char in where clause is not showing properly

Log workAgile BoardRank to TopRank to BottomVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 2.2.0
    • Component/s: None
    • Labels:
      None

      Description

      e.g.,
      CREATE VIEW `v2` AS select `evil_byte1`.`a` from `default`.`EVIL_BYTE1` where `evil_byte1`.`a` = 'abcÖdefÖgh';
      Output:
      ======
      0: jdbc:hive2://172.26.122.227:10000> show create table v2;
      ----------------------------------------------------------------------------------------------------------------+

      createtab_stmt

      ----------------------------------------------------------------------------------------------------------------+

      CREATE VIEW `v2` AS select `evil_byte1`.`a` from `default`.`EVIL_BYTE1` where `evil_byte1`.`a` = 'abc�def�gh'

      ----------------------------------------------------------------------------------------------------------------+

      Only show create output is having invalid characters, actual source table content is displayed properly in the console.

        Attachments

        1. HIVE-18112.1-branch-2.2.patch
          3 kB
          Naresh P R
        2. HIVE-18112.2-branch-2.2.patch
          4 kB
          Naresh P R
        3. HIVE-18112-branch-2.2.patch
          3 kB
          Naresh P R

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment