Details

    • Type: Improvement
    • Status: Patch Available
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Hive
    • Labels:
      None

      Description

      Added a minor change to addressed Sahil's comment on the review board for HIVE-15879 It changes the type of the variable pendingPaths in PathDepthInfoCallable class from ConcurrentLinkedQueue<PathDepthInfo> to a more generic Queue<PathDepthInfo> which makes the class more testable should we want to test it using a mock/custom queue implementation

        Attachments

        1. HIVE-16059.01.patch
          1.0 kB
          Vihang Karajgaonkar

          Issue Links

            Activity

              People

              • Assignee:
                vihangk1 Vihang Karajgaonkar
                Reporter:
                vihangk1 Vihang Karajgaonkar
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: