Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-13487

Finish time is wrong when perflog is missing SUBMIT_TO_RUNNING

Log workAgile BoardRank to TopRank to BottomVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      Sometimes PerfLog misses SUBMIT_TO_RUNNING end time which makes finish time to be wrong. Like below

      Compile Query                           0.60s
      Prepare Plan                            0.44s
      Submit Plan                             0.83s
      Start                                   0.00s
      Finish                              1460423234.44s
      

      NO PRECOMMIT TESTS

        Attachments

        1. HIVE-13487.1.patch
          3 kB
          Prasanth Jayachandran
        2. HIVE-13487.2.patch
          3 kB
          Prasanth Jayachandran

        Issue Links

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

            • Assignee:
              prasanth_j Prasanth Jayachandran Assign to me
              Reporter:
              prasanth_j Prasanth Jayachandran

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment