Hive
  1. Hive
  2. HIVE-1294

HIVE_AUX_JARS_PATH interferes with startup of Hive Web Interface

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6.0
    • Component/s: Web UI
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The Hive Webserver fails to startup with the following error message, if HIVE_AUX_JARS_PATH environment variable is set (works fine if unset).

      $ build/dist/bin/hive --service hwi
      Exception in thread "main" java.io.IOException: Error opening job jar: -libjars
      at org.apache.hadoop.util.RunJar.main(RunJar.java:90)
      Caused by: java.util.zip.ZipException: error in opening zip file
      at java.util.zip.ZipFile.open(Native Method)
      at java.util.zip.ZipFile.<init>(ZipFile.java:114)
      at java.util.jar.JarFile.<init>(JarFile.java:133)
      at java.util.jar.JarFile.<init>(JarFile.java:70)
      at org.apache.hadoop.util.RunJar.main(RunJar.java:88)

      Slightly modifying the command line to launch hadoop in hwi.sh solves the problem:

      $ diff bin/ext/hwi.sh /tmp/new-hwi.sh
      28c28
      < exec $HADOOP jar $AUX_JARS_CMD_LINE $

      {HWI_JAR_FILE} $CLASS $HIVE_OPTS "$@"

      > exec $HADOOP jar ${HWI_JAR_FILE}

      $CLASS $AUX_JARS_CMD_LINE $HIVE_OPTS "$@"

      1. hive-1294.patch.txt
        1 kB
        Edward Capriolo

        Activity

        Dilip Joseph created issue -
        Edward Capriolo made changes -
        Field Original Value New Value
        Assignee Edward Capriolo [ appodictic ]
        Edward Capriolo made changes -
        Priority Minor [ 4 ] Blocker [ 1 ]
        Edward Capriolo made changes -
        Attachment hive-1294.patch.txt [ 12450836 ]
        Edward Capriolo added a comment -

        Hwi does not start correctly without this patch.

        Edward Capriolo made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Fix Version/s 0.6.0 [ 12314524 ]
        John Sichi added a comment -

        +1. Will commit when tests pass.

        John Sichi added a comment -

        Actually I guess tests are pretty much guaranteed to pass since we don't have any.

        John Sichi added a comment -

        Committed to branch and trunk. Thanks Edward!

        John Sichi made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Resolution Fixed [ 1 ]
        Carl Steinbach made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        112d 9h 53m 1 Edward Capriolo 29/Jul/10 16:35
        Patch Available Patch Available Resolved Resolved
        1d 13h 43m 1 John Sichi 31/Jul/10 06:19
        Resolved Resolved Closed Closed
        503d 18h 44m 1 Carl Steinbach 17/Dec/11 00:03

          People

          • Assignee:
            Edward Capriolo
            Reporter:
            Dilip Joseph
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development