Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      It seems to me that for someone who did not want to wipe an existing table but just wanted to add rows to it, that an INSERT APPEND may be desirable. I would expect that the mechanism by which this would take place is the whole normal mapreduce step as if an OVERWRITE were taking place, but the end result would be adding files to the hdfs directory rather than wiping the directory and replacing it with a new one.

      Or failing that, INSERT APPEND could be syntactic sugar for an INSERT OVERWRITE on the same table, but with the SELECT statement replaced with the user-specified SELECT and UNION ALL'd on select * for the existing table...which is my current workaround, but seems like an inelegant query.

        Issue Links

          Activity

          Adam Kramer added a comment -

          Hive-306

          Adam Kramer added a comment -

          Closing in favor of HIVE-306

          Jeff Hammerbacher added a comment -

          Seems like a dupe of HIVE-306; should one of these be closed?


            People

            • Assignee:
              Unassigned
              Reporter:
              Adam Kramer
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development