Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-12406

HIVE-9500 introduced incompatible change to LazySimpleSerDe public interface

    XMLWordPrintableJSON

    Details

      Description

      In the process of fixing HIVE-9500, an incompatibility was introduced that will break 3rd party code that relies on LazySimpleSerde. In HIVE-9500, the nested class SerDeParamaters was removed and the method LazySimpleSerDe.initSerdeParms was also removed. They were replaced by a standalone class LazySerDeParameters.

      Since this has already been released, I don't think we should revert the change since that would mean breaking compatibility again. Instead, the best approach would be to support both interfaces, if possible.

        Attachments

        1. HIVE-12406.patch
          7 kB
          Aihua Xu
        2. HIVE-12406.2.patch
          9 kB
          Aihua Xu

          Issue Links

            Activity

              People

              • Assignee:
                aihuaxu Aihua Xu
                Reporter:
                lskuff Lenni Kuff
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: