Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-11419

hive-shims-0.23 doesn't declare yarn-server-resourcemanager dependency as provided

Log workAgile BoardRank to TopRank to BottomAdd voteVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 1.2.1
    • Fix Version/s: None
    • Component/s: Shims
    • Labels:
      None

      Description

      hive-shims-0.23 doesn't declare its hadoop-yarn-server-resourcemanager dependency as optional, so you get hadoop 2.6.0 on your classpath unless you explicitly excluded it.

      see: [http://mvnrepository.com/artifact/org.apache.hive.shims/hive-shims-0.23/1.2.1]

        Attachments

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

            • Assignee:
              Unassigned Assign to me
              Reporter:
              stevel@apache.org Steve Loughran

              Dates

              • Created:
                Updated:

                Issue deployment