Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-11256

Update release note to clarify hadoop compatibility

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 0.14.0, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0, 1.2.1
    • None
    • Documentation, Website
    • None

    Description

      On the Downloads page: http://hive.apache.org/downloads.html
      We should say "This release works with Hadoop 1.2.0+, 2.x.y" for Hive 0.14+.

      This is due to HIVE-8189 starting using org.apache.hadoop.mapred.JobConf.unset method, which is only available since Hadoop 1.2.0.

      Users using Hadoop versions earlier than that encountered NoSuchMethodError exception:
      e.g. HIVE-11246
      http://stackoverflow.com/questions/28070003/error-while-executing-select-query-in-hive

      Attachments

        Activity

          People

            Unassigned Unassigned
            wzheng Wei Zheng
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: