Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9911

TestDataNodeLifeline Fails intermittently

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 3.0.0-alpha2
    • Component/s: datanode
    • Labels:
      None

      Description

      In HDFS-1312 branch, we have a failure for this test.

      org.apache.hadoop.hdfs.server.datanode.TestDataNodeLifeline.testNoLifelineSentIfHeartbeatsOnTime

      Error Message
      
      Expect metrics to count no lifeline calls. expected:<0> but was:<1>
      Stacktrace
      
      java.lang.AssertionError: Expect metrics to count no lifeline calls. expected:<0> but was:<1>
      	at org.junit.Assert.fail(Assert.java:88)
      	at org.junit.Assert.failNotEquals(Assert.java:743)
      	at org.junit.Assert.assertEquals(Assert.java:118)
      	at org.junit.Assert.assertEquals(Assert.java:555)
      	at org.apache.hadoop.hdfs.server.datanode.TestDataNodeLifeline.testNoLifelineSentIfHeartbeatsOnTime(TestDataNodeLifeline.java:256)
      
      

      Details can be found here.

      https://builds.apache.org/job/PreCommit-HDFS-Build/14726/testReport/org.apache.hadoop.hdfs.server.datanode/TestDataNodeLifeline/testNoLifelineSentIfHeartbeatsOnTime/

      1. HDFS-9911.001.patch
        1 kB
        Yiqun Lin
      2. HDFS-9911.002.patch
        1 kB
        Yiqun Lin

        Issue Links

          Activity

          cnauroth Chris Nauroth added a comment -

          This looks very unusual, because the test failed on an assertion that the metrics didn't count any lifeline RPC calls. However, if there really was an accidental lifeline RPC call, then this is not how the test would fail. Instead, it would fail on the earlier line that verifies there were no lifeline RPC calls by directly looking at the RPC stub spy. Maybe this is a race condition specific to the metrics?

          I don't have a repro at this point, but I'll keep an eye on it.

          cnauroth Chris Nauroth added a comment -

          We just saw another occurrence in a pre-commit run for HDFS-9694.

          https://builds.apache.org/job/PreCommit-HDFS-Build/14748/testReport/

          The symptoms are the same.

          shahrs87 Rushabh S Shah added a comment -

          Another occurrence in a pre-commit for HDFS-10348
          https://builds.apache.org/job/PreCommit-HDFS-Build/15347/testReport/
          Posting here just for additional data point.

          anu Anu Engineer added a comment -
          tasanuma0829 Takanobu Asanuma added a comment -

          Hi, Chris Nauroth. I looked into this issue.

          When building MiniDFSCluster in the setup(), the datanode infrequently sends a lifeline. Then, lifelineNamenode is initialized, but LifelinesNumOps of the datanode is already 1. I think this is the situation.

          We can simulate it by calling DataNodeMetrics#addLifeline in the setup().

          // Set up spies on RPC proxies so that we can inject failures.
          DataNode dn = cluster.getDataNodes().get(0);
          metrics = dn.getMetrics();
          metrics.addLifeline(0);
          
          vinayrpet Vinayakumar B added a comment -

          I think analysis of Takanobu Asanuma makes sense. There is a chance that LifeLineSender sends the lifeline before BPServiceActor sends the heartbeat and postpones the next lifeline.
          I think the problem is in BPServiceActor#Scheduler initial value of nextLifelineTime is same as nextHeartbeatTime and its monotonicNow(), so whichever thread starts first, will send its message. But first Lifeline should atleast wait for lifelineIntervalMs or heartbeatIntervalMs, so that heartbeat can go first. When the heartbeat sent successfully, then onwards lifeline messages will be scheduled properly.

          So following change in BPServiceActor would do the needful I hope.

          @@ -1063,7 +1068,7 @@ private void sendLifeline() throws IOException {
               volatile long nextHeartbeatTime = monotonicNow();
           
               @VisibleForTesting
          -    volatile long nextLifelineTime = monotonicNow();
          +    volatile long nextLifelineTime;
           
               @VisibleForTesting
               volatile long lastBlockReportTime = monotonicNow();
          @@ -1086,6 +1091,7 @@ private void sendLifeline() throws IOException {
                 this.heartbeatIntervalMs = heartbeatIntervalMs;
                 this.lifelineIntervalMs = lifelineIntervalMs;
                 this.blockReportIntervalMs = blockReportIntervalMs;
          +      scheduleNextLifeline(monotonicNow());
               }
           
               // This is useful to make sure NN gets Heartbeat before Blockreport
          
          linyiqun Yiqun Lin added a comment -

          Thanks Takanobu Asanuma and Vinayakumar B for the great analysis. I think that's the root cause of the failure test. I did the test based the change as Vinayakumar B commented, the results seemed ok. Hi Chris Nauroth, are you preparing to work on this, if not, I am ready to post a patch here.

          linyiqun Yiqun Lin added a comment -

          Post a simple patch here, I hope Chris will not mind that since I see this JIRA has been opened for a long time.
          Here I have two ways to fix this:

          • Delay the nextLifelineTime time and to let heartbeat sended first.
          • Use DataNode#setHeartbeatsDisabledForTests(true) to disabled the heratbeat in setup since this also makes sense to disabled lifeline send.

          Here I am prefer to use the first way and I think this is enough to fix this. And that's will make the order of sending messages correct. Softly ping Anu Engineer, could you please have a review? Thanks.

          anu Anu Engineer added a comment -

          Yiqun Lin Thanks for providing the patch. Thanks to Takanobu Asanuma and Vinayakumar B for root causing the issue and suggesting the change that we needed to make.

          +1, pending Jenkins.

          tasanuma0829 Takanobu Asanuma added a comment -

          +1 (non-binding). Thanks, everyone!

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 27s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 9m 25s trunk passed
          +1 compile 0m 57s trunk passed
          +1 checkstyle 0m 32s trunk passed
          +1 mvnsite 1m 5s trunk passed
          +1 mvneclipse 0m 18s trunk passed
          +1 findbugs 2m 8s trunk passed
          +1 javadoc 0m 49s trunk passed
          +1 mvninstall 0m 59s the patch passed
          +1 compile 0m 50s the patch passed
          +1 javac 0m 50s the patch passed
          +1 checkstyle 0m 26s the patch passed
          +1 mvnsite 0m 57s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 2m 4s the patch passed
          +1 javadoc 0m 46s the patch passed
          -1 unit 101m 1s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 20s The patch does not generate ASF License warnings.
          124m 48s



          Reason Tests
          Failed junit tests hadoop.hdfs.server.datanode.TestDataNodeVolumeFailure
            hadoop.hdfs.TestSecureEncryptionZoneWithKMS
            hadoop.hdfs.TestTrashWithSecureEncryptionZones
            hadoop.metrics2.sink.TestRollingFileSystemSinkWithHdfs



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Issue HDFS-9911
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12843138/HDFS-9911.001.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux dc8692af7789 3.13.0-96-generic #143-Ubuntu SMP Mon Aug 29 20:15:20 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / e24a923
          Default Java 1.8.0_111
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/17853/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/17853/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/17853/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          cnauroth Chris Nauroth added a comment -

          Yiqun Lin, thank you for the analysis and volunteering to take over the patch. I am reassigning this to you.

          I suggest changing this to:

          scheduleNextLifeline(nextHeartbeatTime);
          

          This would make it consistent with other points in the code where the lifeline time is scheduled relative to the heartbeat time. It could help avoid confusion if 2 separate calls to monotonicNow() return 2 different timestamps (one for initialization of nextHeartbeatTime and the other for scheduleNextLifeline).

          linyiqun Yiqun Lin added a comment -

          Thanks Anu Engineer, Takanobu Asanuma and Chris Nauroth for the review!

          This would make it consistent with other points in the code where the lifeline time is scheduled relative to the heartbeat time.

          Agree with this. New patch attached.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 17s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 48s trunk passed
          +1 compile 0m 54s trunk passed
          +1 checkstyle 0m 31s trunk passed
          +1 mvnsite 1m 5s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 2m 4s trunk passed
          +1 javadoc 0m 42s trunk passed
          +1 mvninstall 0m 49s the patch passed
          +1 compile 0m 45s the patch passed
          +1 javac 0m 45s the patch passed
          +1 checkstyle 0m 23s the patch passed
          +1 mvnsite 0m 58s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 2m 10s the patch passed
          +1 javadoc 0m 40s the patch passed
          -1 unit 68m 43s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 18s The patch does not generate ASF License warnings.
          90m 50s



          Reason Tests
          Failed junit tests hadoop.hdfs.server.datanode.TestDataNodeUUID
            hadoop.hdfs.TestSecureEncryptionZoneWithKMS
            hadoop.hdfs.TestTrashWithSecureEncryptionZones



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Issue HDFS-9911
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12843205/HDFS-9911.002.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux ed3c0265a896 3.13.0-103-generic #150-Ubuntu SMP Thu Nov 24 10:34:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 72bff19
          Default Java 1.8.0_111
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/17857/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/17857/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/17857/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          linyiqun Yiqun Lin added a comment -

          Hi Anu Engineer, Chris Nauroth, could you please help do the final commit of patch, I see there are no further comments from others now. Thanks.

          anu Anu Engineer added a comment -

          +1 on patch 2.

          anu Anu Engineer added a comment -

          Chris Nauroth Thanks for the code review comments. Yiqun Lin Thank you for the contribution. I have committed this to trunk.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11008 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11008/)
          HDFS-9911. TestDataNodeLifeline Fails intermittently. Contributed by (aengineer: rev a95639068c99ebcaefe8b6c4268449d12a6577d6)

          • (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/BPServiceActor.java
          cnauroth Chris Nauroth added a comment -

          Yiqun Lin, thank you for the patch!

          linyiqun Yiqun Lin added a comment -

          Thanks Anu Engineer for the commit and thanks every one!


            People

            • Assignee:
              linyiqun Yiqun Lin
              Reporter:
              anu Anu Engineer
            • Votes:
              0 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development