Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9527

The return type of FSNamesystem.getBlockCollection should be changed to INodeFile

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      FSNamesystem.getBlockCollection always returns INodeFile. It avoids unnecessary conversion from BlockCollection to INode/INodeFile after the change.

      1. h9527_20151208.patch
        17 kB
        Tsz Wo Nicholas Sze
      2. h9527_20151209.patch
        19 kB
        Tsz Wo Nicholas Sze

        Issue Links

          Activity

          szetszwo Tsz Wo Nicholas Sze added a comment -

          h9527_20151208.patch: split from HDFS-9441

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 4 new or modified test files.
          +1 mvninstall 8m 26s trunk passed
          +1 compile 0m 47s trunk passed with JDK v1.8.0_66
          +1 compile 0m 45s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 18s trunk passed
          +1 mvnsite 0m 55s trunk passed
          +1 mvneclipse 0m 15s trunk passed
          +1 findbugs 2m 0s trunk passed
          +1 javadoc 1m 14s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 57s trunk passed with JDK v1.7.0_91
          +1 mvninstall 0m 52s the patch passed
          +1 compile 0m 46s the patch passed with JDK v1.8.0_66
          +1 javac 0m 46s the patch passed
          +1 compile 0m 44s the patch passed with JDK v1.7.0_91
          +1 javac 0m 44s the patch passed
          -1 checkstyle 0m 17s Patch generated 3 new checkstyle issues in hadoop-hdfs-project/hadoop-hdfs (total was 472, now 472).
          +1 mvnsite 0m 55s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 5s the patch passed
          +1 javadoc 1m 9s the patch passed with JDK v1.8.0_66
          +1 javadoc 1m 53s the patch passed with JDK v1.7.0_91
          -1 unit 57m 34s hadoop-hdfs in the patch failed with JDK v1.8.0_66.
          -1 unit 55m 32s hadoop-hdfs in the patch failed with JDK v1.7.0_91.
          -1 asflicense 0m 23s Patch generated 58 ASF License warnings.
          141m 48s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
            hadoop.hdfs.server.namenode.ha.TestStandbyIsHot
            hadoop.hdfs.TestClientProtocolForPipelineRecovery
          JDK v1.7.0_91 Failed junit tests hadoop.hdfs.TestClientProtocolForPipelineRecovery



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12776458/h9527_20151208.patch
          JIRA Issue HDFS-9527
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 65a6a43dbbb7 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / ada9c2c
          findbugs v3.0.0
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/diff-checkstyle-hadoop-hdfs-project_hadoop-hdfs.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13807/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13807/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13807/console

          This message was automatically generated.

          jingzhao Jing Zhao added a comment -

          Looks like the failure of TestClientProtocolForPipelineRecovery is caused by the exception message change in checkUCBlock. Other than this the patch looks pretty good to me. +1 after fixing the unit test.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          Thanks, Jing. Will fix TestClientProtocolForPipelineRecovery.

          On a second thought, we should change Namesystem.isInSnapshot to pass blockCollectionID and should not change getBlockCollection. Then, Namesystem no longer uses BlockInfo.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          Here is a new patch.

          h9527_20151209.patch

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 5 new or modified test files.
          +1 mvninstall 8m 19s trunk passed
          +1 compile 0m 44s trunk passed with JDK v1.8.0_66
          +1 compile 0m 43s trunk passed with JDK v1.7.0_91
          +1 checkstyle 0m 18s trunk passed
          +1 mvnsite 0m 56s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 1m 57s trunk passed
          +1 javadoc 1m 9s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 53s trunk passed with JDK v1.7.0_91
          +1 mvninstall 0m 51s the patch passed
          +1 compile 0m 47s the patch passed with JDK v1.8.0_66
          +1 javac 0m 47s the patch passed
          +1 compile 0m 45s the patch passed with JDK v1.7.0_91
          +1 javac 0m 45s the patch passed
          -1 checkstyle 0m 17s Patch generated 3 new checkstyle issues in hadoop-hdfs-project/hadoop-hdfs (total was 472, now 472).
          +1 mvnsite 0m 56s the patch passed
          +1 mvneclipse 0m 15s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 19s the patch passed
          +1 javadoc 1m 12s the patch passed with JDK v1.8.0_66
          +1 javadoc 2m 7s the patch passed with JDK v1.7.0_91
          -1 unit 57m 14s hadoop-hdfs in the patch failed with JDK v1.8.0_66.
          -1 unit 56m 28s hadoop-hdfs in the patch failed with JDK v1.7.0_91.
          -1 asflicense 0m 21s Patch generated 58 ASF License warnings.
          142m 49s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
            hadoop.hdfs.TestCrcCorruption
            hadoop.hdfs.server.namenode.TestFileTruncate
          JDK v1.7.0_91 Failed junit tests hadoop.hdfs.TestReplication
            hadoop.hdfs.TestDFSStripedOutputStreamWithFailure060



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12776636/h9527_20151209.patch
          JIRA Issue HDFS-9527
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux c4857dca0d9d 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 50edcb9
          findbugs v3.0.0
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/diff-checkstyle-hadoop-hdfs-project_hadoop-hdfs.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_91.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_91.txt
          JDK v1.7.0_91 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13818/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13818/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13818/console

          This message was automatically generated.

          jingzhao Jing Zhao added a comment -

          The new patch looks good to me. The failed tests should be unrelated. +1

          The failed TestReplication#testNoExtraReplicationWhenBlockReceivedIsLate seems flaky. We can fix it in a separate jira.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          I have committed this.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8949 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8949/)
          HDFS-9527. The return type of FSNamesystem.getBlockCollection should be (szetszwo: rev 132478e805ba0f955345217b8ad87c2d17cccb2d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/Namesystem.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DecommissionManager.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestClientProtocolForPipelineRecovery.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #681 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/681/)
          HDFS-9527. The return type of FSNamesystem.getBlockCollection should be (szetszwo: rev 132478e805ba0f955345217b8ad87c2d17cccb2d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DecommissionManager.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestINodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestClientProtocolForPipelineRecovery.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/Namesystem.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java

            People

            • Assignee:
              szetszwo Tsz Wo Nicholas Sze
              Reporter:
              szetszwo Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development