Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      There are two potential bugs that make the NNThroughputBenchmark$BlockReportStats send empty block reports.

      1. In NNThroughputBenchmark$BlockReportStats#formBlockReport(), the blockReportList is always BlockListAsLongs.EMPTY. We should construct the block report list by encoding generated blocks in test.
      2. TinyDatanode#blocks is an empty ArrayList with initial capacity. In TinyDatanode#addBlock() first statement, the if(nrBlocks == blocks.size()) { will always be true. We should either fill the blocks with dummy report in TinyDatanode() constructor, or use initial capacity instead of blocks.size() in the above if statement (we should replace ArrayList#set with ArrayList#add as well).
      1. HDFS-9484.001.patch
        2 kB
        Mingliang Liu
      2. HDFS-9484.000.patch
        2 kB
        Mingliang Liu

        Issue Links

          Activity

          leftnoteasy Wangda Tan added a comment -

          Committed to branch-2.8.

          hudson Hudson added a comment -

          ABORTED: Integrated in Hadoop-Hdfs-trunk-Java8 #663 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/663/)
          HDFS-9484. NNThroughputBenchmark$BlockReportStats should not send empty (shv: rev 924a33d02d82adef11a56bf97ff4100c567d9e5d)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/NNThroughputBenchmark.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8916 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8916/)
          HDFS-9484. NNThroughputBenchmark$BlockReportStats should not send empty (shv: rev 924a33d02d82adef11a56bf97ff4100c567d9e5d)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/NNThroughputBenchmark.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          shv Konstantin Shvachko added a comment -

          I just committed this. Thank you Mingliang Liu.

          liuml07 Mingliang Liu added a comment -

          Konstantin Shvachko Thank you very much for your review, discussion and commit!

          shv Konstantin Shvachko added a comment -

          +1
          Will commit both shortly.

          liuml07 Mingliang Liu added a comment -

          The failing tests seem unrelated.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 9m 11s trunk passed
          +1 compile 0m 53s trunk passed with JDK v1.8.0_66
          +1 compile 0m 50s trunk passed with JDK v1.7.0_85
          +1 checkstyle 0m 19s trunk passed
          +1 mvnsite 1m 6s trunk passed
          +1 mvneclipse 0m 16s trunk passed
          +1 findbugs 2m 16s trunk passed
          +1 javadoc 1m 23s trunk passed with JDK v1.8.0_66
          +1 javadoc 2m 14s trunk passed with JDK v1.7.0_85
          +1 mvninstall 0m 59s the patch passed
          +1 compile 0m 55s the patch passed with JDK v1.8.0_66
          +1 javac 0m 55s the patch passed
          +1 compile 0m 50s the patch passed with JDK v1.7.0_85
          +1 javac 0m 50s the patch passed
          +1 checkstyle 0m 19s the patch passed
          +1 mvnsite 1m 3s the patch passed
          +1 mvneclipse 0m 16s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 23s the patch passed
          +1 javadoc 1m 23s the patch passed with JDK v1.8.0_66
          +1 javadoc 2m 13s the patch passed with JDK v1.7.0_85
          -1 unit 74m 2s hadoop-hdfs in the patch failed with JDK v1.8.0_66.
          -1 unit 64m 16s hadoop-hdfs in the patch failed with JDK v1.7.0_85.
          -1 asflicense 0m 24s Patch generated 58 ASF License warnings.
          170m 55s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
            hadoop.hdfs.server.mover.TestStorageMover
            hadoop.hdfs.server.namenode.TestFSImageWithXAttr
            hadoop.hdfs.server.datanode.TestBlockReplacement
            hadoop.hdfs.server.datanode.TestDataNodeMetrics
            hadoop.hdfs.server.namenode.ha.TestHAMetrics
          JDK v1.7.0_85 Failed junit tests hadoop.hdfs.TestDFSStripedOutputStream
            hadoop.hdfs.server.namenode.snapshot.TestSnapshotMetrics
            hadoop.hdfs.server.datanode.TestBlockReplacement
            hadoop.hdfs.TestDFSStripedOutputStreamWithFailure050



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12775468/HDFS-9484.001.patch
          JIRA Issue HDFS-9484
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 5ac942c4b394 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / e8bd1ba
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13745/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13745/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13745/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-HDFS-Build/13745/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85.txt
          JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13745/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13745/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13745/console

          This message was automatically generated.

          liuml07 Mingliang Liu added a comment -

          Thanks for the comment, Konstantin Shvachko.

          I totally agree with you that the code snippet above is better as the code change is small and simple. The v1 patch is to address this.

          It's worth to note that the Arrays.asList returns a java.util.Arrays.ArrayList object, which implements the List interface. The v1 patch changes the blocks type from ArrayList to List. Given that we don't add/delete items to/from this list, I think the List interface works just as fine as ArrayList.

          shv Konstantin Shvachko added a comment -

          Yes indeed nrBlocks == blocks.size() always, because both are 0.
          Wouldn't it be easier to change the constructor of TinyDatanode

          -       this.blocks = new ArrayList<BlockReportReplica>(blockCapacity);
          +       this.blocks = Arrays.asList(new BlockReportReplica[blockCapacity]);
          

          Then the set logic will work as intended.

          The blockReportList part looks good.

          liuml07 Mingliang Liu added a comment -

          Failing tests are not related and can not re-produce locally.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 0s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 8m 9s trunk passed
          +1 compile 0m 46s trunk passed with JDK v1.8.0_66
          +1 compile 0m 46s trunk passed with JDK v1.7.0_85
          +1 checkstyle 0m 17s trunk passed
          +1 mvnsite 0m 57s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 2m 7s trunk passed
          +1 javadoc 1m 12s trunk passed with JDK v1.8.0_66
          +1 javadoc 1m 55s trunk passed with JDK v1.7.0_85
          +1 mvninstall 0m 51s the patch passed
          +1 compile 0m 52s the patch passed with JDK v1.8.0_66
          -1 javac 6m 57s hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66 with JDK v1.8.0_66 generated 2 new issues (was 33, now 33).
          +1 javac 0m 52s the patch passed
          +1 compile 0m 45s the patch passed with JDK v1.7.0_85
          -1 javac 7m 42s hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85 with JDK v1.7.0_85 generated 2 new issues (was 35, now 35).
          +1 javac 0m 45s the patch passed
          +1 checkstyle 0m 17s the patch passed
          +1 mvnsite 0m 55s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 11s the patch passed
          +1 javadoc 1m 16s the patch passed with JDK v1.8.0_66
          +1 javadoc 2m 1s the patch passed with JDK v1.7.0_85
          -1 unit 56m 58s hadoop-hdfs in the patch failed with JDK v1.8.0_66.
          +1 unit 54m 30s hadoop-hdfs in the patch passed with JDK v1.7.0_85.
          -1 asflicense 0m 22s Patch generated 58 ASF License warnings.
          140m 33s



          Reason Tests
          JDK v1.8.0_66 Failed junit tests hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
            hadoop.hdfs.TestDFSStripedOutputStreamWithFailure020
            hadoop.hdfs.server.blockmanagement.TestBlocksWithNotEnoughRacks
            hadoop.hdfs.TestDFSStripedOutputStreamWithFailure190



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:0ca8df7
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12775107/HDFS-9484.000.patch
          JIRA Issue HDFS-9484
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux a8d4864cd154 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 1cc7e61
          findbugs v3.0.0
          javac hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66: https://builds.apache.org/job/PreCommit-HDFS-Build/13718/artifact/patchprocess/diff-compile-javac-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          javac hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85: https://builds.apache.org/job/PreCommit-HDFS-Build/13718/artifact/patchprocess/diff-compile-javac-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13718/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13718/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
          JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13718/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13718/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 76MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13718/console

          This message was automatically generated.

          liuml07 Mingliang Liu added a comment -

          Thanks Colin P. McCabe for your confirmation. I updated the jira description to add another potential bug that makes the BlockReportStats send empty block reports. Would you help me check that out as well?

          cmccabe Colin P. McCabe added a comment -

          Good find, Mingliang Liu.


            People

            • Assignee:
              liuml07 Mingliang Liu
              Reporter:
              liuml07 Mingliang Liu
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development