Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9357

NN UI renders icons of decommissioned DN incorrectly

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      NN UI is not showing which DN is "Decommissioned "and "Decommissioned & dead"

      Root Cause –
      "Decommissioned" and "Decommissioned & dead" icon not reflected on NN UI

      When DN is in Decommissioned status or in "Decommissioned & dead" status, same status is not reflected on NN UI

      DN status is as below –

      hdfs dfsadmin -report

      Name: 10.xx.xx.xx1:50076 (host-xx1)
      Hostname: host-xx
      Decommission Status : Decommissioned
      Configured Capacity: 230501634048 (214.67 GB)
      DFS Used: 36864 (36 KB)

      Dead datanodes (1):
      Name: 10.xx.xx.xx2:50076 (host-xx2)
      Hostname: host-xx
      Decommission Status : Decommissioned

      Same is not reflected on NN UI.

      Attached NN UI snapshots for the same.

      1. decommisioned_n_dead_.png
        28 kB
        Archana T
      2. decommissioned_.png
        29 kB
        Archana T
      3. Decommissioned_Dead_Fixed.PNG
        8 kB
        Surendra Singh Lilhore
      4. Decommissioned_Fixed.PNG
        7 kB
        Surendra Singh Lilhore
      5. HDFS-9357.001.patch
        2 kB
        Surendra Singh Lilhore
      6. HDFS-9357.001.patch
        2 kB
        Surendra Singh Lilhore

        Issue Links

          Activity

          kshukla Kuhu Shukla added a comment -

          Haohui Mai, Surendra Singh Lilhore, I think it would be a good cherry pick for 2.7. Let me know your thoughts on that. Thanks a lot.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2510 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2510/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #572 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/572/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2569 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2569/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #639 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/639/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #627 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/627/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #1361 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1361/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8756 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8756/)
          HDFS-9357. NN UI renders icons of decommissioned DN incorrectly. (wheat9: rev 0eed886a165f5a0850ddbfb1d5f98c7b5e379fb3)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/static/hadoop.css
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          wheat9 Haohui Mai added a comment -

          I've committed the patch to trunk and branch-2. Thanks Surendra Singh Lilhore for the contribution.

          hadoopqa Hadoop QA added a comment -
          +1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 5s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 whitespace 0m 1s Patch has no whitespace issues.
          +1 asflicense 0m 28s Patch does not generate ASF License warnings.
          0m 39s



          Subsystem Report/Notes
          Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-04
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770528/HDFS-9357.001.patch
          JIRA Issue HDFS-9357
          Optional Tests asflicense
          uname Linux f1819eab5fbd 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/patchprocess/apache-yetus-d0f6847/precommit/personality/hadoop.sh
          git revision trunk / 194251c
          Default Java 1.7.0_79
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 32MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13377/console

          This message was automatically generated.

          surendrasingh Surendra Singh Lilhore added a comment -

          Resubmitting patch to trigger jenkins..

          wheat9 Haohui Mai added a comment -

          +1 pending jenkins.

          surendrasingh Surendra Singh Lilhore added a comment -

          This issue came because of typo in hadoop.css and dfshealth.html
          Attached patch, please review


            People

            • Assignee:
              surendrasingh Surendra Singh Lilhore
              Reporter:
              archanat Archana T
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development