Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9226

MiniDFSCluster leaks dependency Mockito via DataNodeTestUtils

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Noticed a test failure when attempting to run Accumulo unit tests against 2.8.0-SNAPSHOT:

      java.lang.NoClassDefFoundError: org/mockito/stubbing/Answer
      	at org.apache.hadoop.hdfs.MiniDFSCluster.shouldWait(MiniDFSCluster.java:2421)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.waitActive(MiniDFSCluster.java:2323)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.waitActive(MiniDFSCluster.java:2367)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.startDataNodes(MiniDFSCluster.java:1529)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:841)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:479)
      	at org.apache.hadoop.hdfs.MiniDFSCluster$Builder.build(MiniDFSCluster.java:438)
      	at org.apache.accumulo.start.test.AccumuloDFSBase.miniDfsClusterSetup(AccumuloDFSBase.java:67)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
      	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
      	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
      	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
      	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
      	at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:283)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(JUnit4Provider.java:173)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:153)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:128)
      	at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:203)
      	at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:155)
      	at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:103)
      Caused by: java.lang.ClassNotFoundException: org.mockito.stubbing.Answer
      	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
      	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.shouldWait(MiniDFSCluster.java:2421)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.waitActive(MiniDFSCluster.java:2323)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.waitActive(MiniDFSCluster.java:2367)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.startDataNodes(MiniDFSCluster.java:1529)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.initMiniDFSCluster(MiniDFSCluster.java:841)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:479)
      	at org.apache.hadoop.hdfs.MiniDFSCluster$Builder.build(MiniDFSCluster.java:438)
      	at org.apache.accumulo.start.test.AccumuloDFSBase.miniDfsClusterSetup(AccumuloDFSBase.java:67)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
      	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
      	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
      	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:24)
      	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
      	at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:283)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(JUnit4Provider.java:173)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:153)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:128)
      	at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:203)
      	at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:155)
      	at org.apache.maven.surefire.booter.ForkedBooter.main
      

      This happens on the call to DataNodeTestUtils.getFSDataset because it imports some Mockito classes.

      It would be desirable to either have the Mockito dependency pulled in transitively (it's currently listed in test scope for the hadoop-hdfs module which means it isn't automatically pulled in when projects depend on hadoop-minicluster) or remove the need for Mockito entirely (IMO, the better choice).

      I'll try to get a patch up for this, but if someone can beat me to it, feel free to reassign to yourself.

      1. HDFS-9226.001.patch
        40 kB
        Josh Elser
      2. HDFS-9226.002.patch
        39 kB
        Josh Elser
      3. HDFS-9226.003.patch
        39 kB
        Josh Elser
      4. HDFS-9226.004.patch
        37 kB
        Josh Elser
      5. HDFS-9226.005.patch
        0.5 kB
        Josh Elser
      6. HDFS-9926.006.patch
        41 kB
        Josh Elser

        Issue Links

          Activity

          elserj Josh Elser added a comment -

          FYI, Kanaka Kumar Avvaru, Vinayakumar B, Arpit Agarwal, Steve Loughran since you all have reviewed HDFS-8953 originally.

          elserj Josh Elser added a comment -

          001 takes the route of just moving the test utilities that rely on Mockito to an altogether different class. This should prevent MiniDFSCluster from pulling it in inadvertently.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 patch 0m 0s The patch command could not apply the patch during dryrun.



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12766042/HDFS-9226.001.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / db93047
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12926/console

          This message was automatically generated.

          elserj Josh Elser added a comment -

          002 is the same patch as 001 except for one removed changeset in which the test was removed in trunk.

          001 -> branch-2
          002 -> trunk

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 8m 31s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 19 new or modified test files.
          +1 javac 8m 30s There were no new javac warning messages.
          -1 release audit 0m 17s The applied patch generated 1 release audit warnings.
          +1 checkstyle 1m 33s There were no new checkstyle issues.
          -1 whitespace 0m 1s The patch has 3 line(s) that end in whitespace. Use git apply --whitespace=fix.
          +1 install 1m 34s mvn install still works.
          +1 eclipse:eclipse 0m 34s The patch built with eclipse:eclipse.
          +1 findbugs 2m 40s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 1m 8s Pre-build of native portion
          -1 hdfs tests 225m 34s Tests failed in hadoop-hdfs.
              250m 25s  



          Reason Tests
          Failed unit tests hadoop.hdfs.TestCrcCorruption



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12766043/HDFS-9226.002.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / db93047
          Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12927/artifact/patchprocess/patchReleaseAuditProblems.txt
          whitespace https://builds.apache.org/job/PreCommit-HDFS-Build/12927/artifact/patchprocess/whitespace.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12927/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12927/testReport/
          Java 1.7.0_55
          uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12927/console

          This message was automatically generated.

          iwasakims Masatake Iwasaki added a comment -

          Mockito has been used for a long time by DataNodeTestUtils. Had the test worked before HDFS-8953 came in?

          According to MNG-1378, dependency of test-jar is not transitive by design. Dependencies other than Mockito are possible to have same problem. Should we add explicit dependency to pom.xml of hadoop-minicluster rather than fixing test code every time the issue rises?

          elserj Josh Elser added a comment -

          RAT is a false positive and the test failure appears sporadic (passed locally anyways), but the whitespace was all me. Fixed in 003.

          The patch did fix the Accumulo unit tests (as outlined in the description).

          elserj Josh Elser added a comment -

          Thanks for taking a look, Masatake Iwasaki.

          Mockito has been used for a long time by DataNodeTestUtils. Had the test worked before HDFS-8953 came in?

          I didn't explicitly track it down, but I can say with confidence that it does work with <=2.8.0-SNAPSHOT.

          dependency of test-jar is not transitive by design

          Precisely. That is the root of the issue described here.

          Should we add explicit dependency to pom.xml of hadoop-minicluster rather than fixing test code every time the issue rises?

          While there's the long-term maintenance worry here in Hadoop, adding in Mockito is also a scary consideration as it's yet another forced dependency on clients for something that, personally, looks extremely minor. I have to imagine that there are ways we could catch that in the future too. I'm also open other suggestions to future proof things

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 8m 52s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 19 new or modified test files.
          +1 javac 8m 56s There were no new javac warning messages.
          -1 release audit 0m 18s The applied patch generated 1 release audit warnings.
          +1 checkstyle 1m 36s There were no new checkstyle issues.
          +1 whitespace 0m 1s The patch has no lines that end in whitespace.
          +1 install 1m 40s mvn install still works.
          +1 eclipse:eclipse 0m 38s The patch built with eclipse:eclipse.
          +1 findbugs 2m 56s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 1m 25s Pre-build of native portion
          -1 hdfs tests 196m 16s Tests failed in hadoop-hdfs.
              222m 41s  



          Reason Tests
          Failed unit tests hadoop.hdfs.TestReplaceDatanodeOnFailure
          Timed out tests org.apache.hadoop.hdfs.TestRollingUpgradeDowngrade
            org.apache.hadoop.hdfs.server.namenode.TestAddStripedBlocks



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12766064/HDFS-9226.003.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / db93047
          Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12928/artifact/patchprocess/patchReleaseAuditProblems.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12928/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12928/testReport/
          Java 1.7.0_55
          uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12928/console

          This message was automatically generated.

          iwasakims Masatake Iwasaki added a comment -

          Hmm... Though test artifacts are intended to be internal, MiniDFSCluster seems to be exception and annotated as LimitedPrivate.

          @InterfaceAudience.LimitedPrivate({"HBase", "HDFS", "Hive", "MapReduce", "Pig"})
          @InterfaceStability.Unstable
          public class MiniDFSCluster {
          

          If MiniDFSCluster alone is used by downstream projects, it should not depends on artifacts only depended by test-jar of hadoop-* as far as possible but there is no guard for this now. Maybe we can add test checking it to hadoop-minicluster as follow-up.

          Anyway, I have some comments on the patch.

          • There is no guard to keep someone from adding code using InternalDataNodeTestUtils to MiniDFSCluster.
          • The class name InternalDataNodeTestUtils is not clear because test artifacts are originally internal. It should be DataNodeMockUtils or something?
          iwasakims Masatake Iwasaki added a comment -

          There is no guard to keep someone from adding code using InternalDataNodeTestUtils to MiniDFSCluster.

          Please ignore this one.This is not a comment for the patch... I have one more comment instead.

          • imports added to TestDataNodeMetricsLogger are not used.
          elserj Josh Elser added a comment -

          The class name InternalDataNodeTestUtils is not clear because test artifacts are originally internal. It should be DataNodeMockUtils or something?

          I am very open to name suggestions. My only concern was naming it something that wasn't specifically tied to Mockito. DataNodeMockUtils works for me.

          Let me get a new patch up. Thanks again, Masatake!

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 8m 9s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 19 new or modified test files.
          +1 javac 8m 9s There were no new javac warning messages.
          -1 release audit 0m 18s The applied patch generated 1 release audit warnings.
          +1 checkstyle 1m 26s There were no new checkstyle issues.
          +1 whitespace 0m 1s The patch has no lines that end in whitespace.
          +1 install 1m 30s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 2m 30s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 1m 15s Pre-build of native portion
          -1 hdfs tests 234m 7s Tests failed in hadoop-hdfs.
              258m 3s  



          Reason Tests
          Failed unit tests hadoop.hdfs.server.namenode.TestAddBlockRetry
            hadoop.hdfs.TestReplaceDatanodeOnFailure
            hadoop.hdfs.web.TestWebHDFSXAttr



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12766164/HDFS-9226.004.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / 9849c8b
          Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12935/artifact/patchprocess/patchReleaseAuditProblems.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12935/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12935/testReport/
          Java 1.7.0_55
          uname Linux asf905.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12935/console

          This message was automatically generated.

          iwasakims Masatake Iwasaki added a comment -

          Thanks for the update, Josh Elser. Though the patch looks good to me, I would like opinions of another developers opinion about which option is better.

          • fix DataNodeTestUtils as this JIRA proposes
          • add mockito as compile scope dependency to pom.xml of hadoop-minicluster
          • add comment/documenation about dependency for downstream projects and leave the code as is
          iwasakims Masatake Iwasaki added a comment -

          adding in Mockito is also a scary consideration as it's yet another forced dependency on clients for something that, personally, looks extremely minor.

          hadoop-minicluster is intended to be used in tests. Adding mockito as test scope dependency does not affect users of your artifacts and it would be quick fix for this issue.

          vinayrpet Vinayakumar B added a comment -

          hadoop-minicluster is intended to be used in tests. Adding mockito as test scope dependency does not affect users of your artifacts and it would be quick fix for this issue.

          I agree with this. Adding mockito as dependency would be better. Every other changes in hdfs tests need not verify for transitive dependencies.

          Dependencies other than Mockito are possible to have same problem

          Exactly. IMO, HDFS-8953, just exposed this existing problem.

          elserj Josh Elser added a comment -

          I agree with this. Adding mockito as dependency would be better. Every other changes in hdfs tests need not verify for transitive dependencies.

          I still disagree with you both – claiming ignorance of the used dependencies your code needs is a smell to begin with and keeping the dependencies as minimal as possible always desirable. The maven-dependency-plugin's analyze mojo would be a way to automate this check.

          But, since two of you are leaning this way, let me try that and see what else breaks

          elserj Josh Elser added a comment -

          Well, I thought this would be simple, but it seems like I might be running into some fallout from HDFS-9166:

          testCleanupIndexOpWithDfsDir(org.apache.accumulo.server.util.FileUtilTest)  Time elapsed: 0.003 sec  <<< ERROR!
          java.util.ServiceConfigurationError: org.apache.hadoop.fs.FileSystem: Provider org.apache.hadoop.hdfs.web.HftpFileSystem not found
          	at java.util.ServiceLoader.fail(ServiceLoader.java:231)
          	at java.util.ServiceLoader.access$300(ServiceLoader.java:181)
          	at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:365)
          	at java.util.ServiceLoader$1.next(ServiceLoader.java:445)
          	at org.apache.hadoop.fs.FileSystem.loadFileSystems(FileSystem.java:2661)
          	at org.apache.hadoop.fs.FileSystem.getFileSystemClass(FileSystem.java:2672)
          	at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2693)
          	at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:95)
          	at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2732)
          	at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2714)
          	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:375)
          	at org.apache.hadoop.fs.FileSystem.getLocal(FileSystem.java:346)
          	at org.apache.accumulo.server.fs.VolumeManagerImpl.getLocal(VolumeManagerImpl.java:94)
          	at org.apache.accumulo.server.util.FileUtilTest.testCleanupIndexOpWithDfsDir(FileUtilTest.java:98)
          

          Looks like META-INF service definition isn't getting picked up correctly. I'll have to dig into this more tonight and figure out what the heck is going on. Pulling in Mockito at least doesn't appear to be causing more immediate problems. Let me attach a patch for that meanwhile.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 21m 22s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 10m 36s There were no new javac warning messages.
          +1 javadoc 13m 25s There were no new javadoc warning messages.
          +1 release audit 0m 32s The applied patch does not increase the total number of release audit warnings.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 51s mvn install still works.
          +1 eclipse:eclipse 0m 44s The patch built with eclipse:eclipse.
          +1 minicluster tests 0m 19s Tests passed in hadoop-minicluster.
              48m 53s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12766619/HDFS-9226.005.patch
          Optional Tests javadoc javac unit
          git revision trunk / dfa7848
          hadoop-minicluster test log https://builds.apache.org/job/PreCommit-HDFS-Build/12986/artifact/patchprocess/testrun_hadoop-minicluster.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12986/testReport/
          Java 1.7.0_55
          uname Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12986/console

          This message was automatically generated.

          iwasakims Masatake Iwasaki added a comment -

          Every other changes in hdfs tests need not verify for transitive dependencies.

          Not for other changes in tests but only Mini(DFS|YARN)Cluster is desirable to work by just adding hadoop-minicluster as dependency. I filed HADOOP-12477 addressing this.

          elserj Josh Elser added a comment -

          Anything else that needs to be done here? This at least fixed the problem I was seeing in Accumulo tests against 2.8.0-SNAPSHOT.

          arpitagarwal Arpit Agarwal added a comment -

          Hi Josh Elser, thanks for taking this up. I must confess I don't understand how HDFS-8953 introduced this. DataNodeTestUtils already had a prior dependency on Mockito.

          elserj Josh Elser added a comment -

          I must confess I don't understand how HDFS-8953 introduced this. DataNodeTestUtils already had a prior dependency on Mockito.

          I'd have to go back and look at the commit, but I think it was just MiniDFSCluster calling a method in DataNodeTestUtils which it didn't previously. Once that import was added, DataNodeTestUtils got loaded due to MiniDFSCluster's import, and then failed because of that Mockito import. Would have to dbl check to be certain

          iwasakims Masatake Iwasaki added a comment -
          277	    Mockito.doAnswer(new Answer<DatanodeRegistration>() {
          278	      @Override
          279	      public DatanodeRegistration answer(InvocationOnMock invocation)
          280	          throws Throwable {
          281	        return (DatanodeRegistration) invocation.getArguments()[0];
          282	      }
          283	    }).when(namenode).registerDatanode(Mockito.any(DatanodeRegistration.class));
          

          Arpit Agarwal, this code added to DataNodeTestUtils by HDFS-8953 seemed to make Mockito loaded on loading DataNodeTestUtils. Though Mockito has been used for a long time by DataNodeTestUtils, on demand class loading of JVM had not needed it in the code path of MiniDFSCluster before HDFS-8953 came in.

          Test in HADOOP-12477 suceeded without mockito dependency by commenting out above.

          arpitagarwal Arpit Agarwal added a comment -

          Thanks Masatake Iwasaki, we should eliminate the new dependency i.e. I'd be +1 for Josh Elser's v4 patch. I see Josh also moved over the existing Mockito uses in DatanodeTestUtils so this removes the current ambiguity.

          elserj Josh Elser added a comment -

          .006 This one came across my radar again today, so here's a rebase on top of master. Best as I can tell this approach works (I believe my original downstream test is passing).

          elserj Josh Elser added a comment -

          so here's a rebase on top of master.

          Oh my. master is not what I thought it was.. let me try again.

          elserj Josh Elser added a comment -

          .006 Rebased .004 on top of the correct "trunk" branch

          arpitagarwal Arpit Agarwal added a comment -

          +1 pending Jenkins. Thank you Josh Elser!

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 12s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 21 new or modified test files.
          +1 mvninstall 7m 26s trunk passed
          +1 compile 0m 50s trunk passed
          +1 checkstyle 0m 35s trunk passed
          +1 mvnsite 0m 58s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 1m 48s trunk passed
          +1 javadoc 1m 7s trunk passed
          +1 mvninstall 0m 51s the patch passed
          +1 compile 0m 49s the patch passed
          +1 javac 0m 49s the patch passed
          -1 checkstyle 0m 33s hadoop-hdfs-project/hadoop-hdfs: patch generated 18 new + 557 unchanged - 18 fixed = 575 total (was 575)
          +1 mvnsite 0m 59s the patch passed
          +1 mvneclipse 0m 12s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 1m 52s the patch passed
          +1 javadoc 1m 7s the patch passed
          -1 unit 66m 0s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 18s Patch does not generate ASF License warnings.
          87m 11s



          Reason Tests
          Failed junit tests hadoop.hdfs.server.datanode.TestFsDatasetCache
            hadoop.hdfs.TestDFSUpgradeFromImage
            hadoop.hdfs.server.namenode.TestEditLog
            hadoop.hdfs.TestAsyncDFSRename



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:2c91fd8
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12804577/HDFS-9926.006.patch
          JIRA Issue HDFS-9226
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 239906e34310 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 8a9ecb7
          Default Java 1.8.0_91
          findbugs v3.0.0
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/15469/artifact/patchprocess/diff-checkstyle-hadoop-hdfs-project_hadoop-hdfs.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/15469/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/15469/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/15469/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/15469/console
          Powered by Apache Yetus 0.2.0 http://yetus.apache.org

          This message was automatically generated.

          elserj Josh Elser added a comment -

          Hrm, let me take a look at these unit test failures and checkstyle. I can fix these.

          arpitagarwal Arpit Agarwal added a comment - - edited

          Test failures were not caused by the patch (verified all tests passed for me locally with the v06 patch applied). The checkstyle warnings were not introduced by your patch either.

          I will commit this shortly.

          arpitagarwal Arpit Agarwal added a comment -

          Committed to trunk through branch-2.8.

          Thank you for taking care of this Josh Elser.

          elserj Josh Elser added a comment -

          Test failures were not caused by the patch (verified all tests passed for me locally with the v06 patch applied). The checkstyle warnings were not introduced by your patch either.

          Oh, ok.

          Thank you for taking care of this Josh Elser.

          Any time. Thanks for the commit.

          arpitagarwal Arpit Agarwal added a comment -

          Also thanks to Vinayakumar B and Masatake Iwasaki for the earlier reviews and diagnosis.

          andrew.wang Andrew Wang added a comment -

          Note for future git log greppers, JIRA ID typo'd as HDFS-9926.


            People

            • Assignee:
              elserj Josh Elser
              Reporter:
              elserj Josh Elser
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development