Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Tests run: 7, Failures: 2, Errors: 0, Skipped: 0, Time elapsed: 181.278 sec <<< FAILURE! - in org.apache.hadoop.hdfs.web.TestWebHdfsContentLength
      testPutOp(org.apache.hadoop.hdfs.web.TestWebHdfsContentLength) Time elapsed: 60.05 sec <<< FAILURE!
      java.lang.AssertionError: expected:<0> but was:<null>
      at org.junit.Assert.fail(Assert.java:88)
      at org.junit.Assert.failNotEquals(Assert.java:743)
      at org.junit.Assert.assertEquals(Assert.java:118)
      at org.junit.Assert.assertEquals(Assert.java:144)
      at org.apache.hadoop.hdfs.web.TestWebHdfsContentLength.testPutOp(TestWebHdfsContentLength.java:116)

      testPutOpWithRedirect(org.apache.hadoop.hdfs.web.TestWebHdfsContentLength) Time elapsed: 0.01 sec <<< FAILURE!
      org.junit.ComparisonFailure: expected:<[chunked]> but was:<[0]>
      at org.junit.Assert.assertEquals(Assert.java:115)
      at org.junit.Assert.assertEquals(Assert.java:144)
      at org.apache.hadoop.hdfs.web.TestWebHdfsContentLength.testPutOpWithRedirect(TestWebHdfsContentLength.java:130)

      1. HDFS-9196.001.patch
        0.9 kB
        Masatake Iwasaki

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #465 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/465/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2403 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2403/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #492 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/492/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #500 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/500/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #1229 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1229/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2435 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2435/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8584 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8584/)
        HDFS-9196. Fix TestWebHdfsContentLength. Contributed by Masatake (jing9: rev 239d119c6707e58c9a5e0099c6d65fe956e95140)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/web/WebHdfsFileSystem.java
        jingzhao Jing Zhao added a comment -

        The patch looks good to me. +1. I've committed the fix to trunk and 2.8. Thanks for the fix, Masatake Iwasaki! Thanks for reporting the issue, Tsuyoshi Ozawa! And thanks for the review, Mingliang Liu!

        iwasakims Masatake Iwasaki added a comment -

        Thanks, Mingliang Liu. Checkstyle and release audit warnings are not related to the fixed line.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        -1 pre-patch 19m 44s Pre-patch trunk has 7 extant Findbugs (version 3.0.0) warnings.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 javac 8m 54s There were no new javac warning messages.
        +1 javadoc 11m 21s There were no new javadoc warning messages.
        -1 release audit 0m 17s The applied patch generated 1 release audit warnings.
        +1 checkstyle 1m 47s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 40s mvn install still works.
        +1 eclipse:eclipse 0m 36s The patch built with eclipse:eclipse.
        +1 findbugs 2m 16s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 3m 31s Pre-build of native portion
        +1 hdfs tests 0m 30s Tests passed in hadoop-hdfs-client.
            50m 42s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765020/HDFS-9196.001.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 29a582a
        Pre-patch Findbugs warnings https://builds.apache.org/job/PreCommit-HDFS-Build/12815/artifact/patchprocess/trunkFindbugsWarningshadoop-hdfs-client.html
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12815/artifact/patchprocess/patchReleaseAuditProblems.txt
        hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/12815/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12815/testReport/
        Java 1.7.0_55
        uname Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12815/console

        This message was automatically generated.

        liuml07 Mingliang Liu added a comment -

        Thank you for this patch. I checked it out and also found the same reason.

        The revert patch looks good to me.

        iwasakims Masatake Iwasaki added a comment -

        The cause is the change of WebHdfsFileSystem by HDFS-8979. Attached patch revert the 1 line.

        @@ -207,7 +212,7 @@ public synchronized void initialize(URI uri, Configuration conf
                       failoverSleepMaxMillis);
             }
         
        -    this.workingDir = makeQualified(new Path(getHomeDirectoryString(ugi)));
        +    this.workingDir = makeQualified(getHomeDirectory());
             this.canRefreshDelegationToken = UserGroupInformation.isSecurityEnabled();
             this.disallowFallbackToInsecureCluster = !conf.getBoolean(
                 CommonConfigurationKeys.IPC_CLIENT_FALLBACK_TO_SIMPLE_AUTH_ALLOWED_KEY,
        

        QA build seems not able to detect this bug because fixing WebHdfsFileSystem in hadoop-hdfs-client does not result in checking TestWebHdfsContentLength is in hadoop-hdfs.


          People

          • Assignee:
            iwasakims Masatake Iwasaki
            Reporter:
            ozawa Tsuyoshi Ozawa
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development