Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-913

TestRename won't run automatically from 'run-test-hdfs-faul-inject' target

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      HDFS-913. Rename fault injection test TestRename.java to TestFiRename.java to include it in tests run by ant target run-test-hdfs-fault-inject.
      Show
      HDFS-913 . Rename fault injection test TestRename.java to TestFiRename.java to include it in tests run by ant target run-test-hdfs-fault-inject.

      Description

      Fault injection test classes suppose to have TestFi prefix. Otherwise, JUnit target won't pick them up as a part of the batch test run. Although, it's still possible to run test with different names with -Dtestcase= directive.

      1. hdfs-913.patch
        3 kB
        Suresh Srinivas

        Activity

        Suresh Srinivas added a comment -

        I want to use "svn move" command to make this change to preserve the history of the file. However the generated patch does not have details of new file. I would like to commit this change without generating patch.

        Konstantin Boudnik added a comment -

        Makes sense.

        +1 on the 'svn move' patch

        Suresh Srinivas added a comment -

        I committed the change.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #194 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/194/)
        . Rename fault injection test TestRename.java to TestFiRename.java to include it in tests run by ant target run-test-hdfs-fault-inject. Contributed by Suresh Srinivas.

        Konstantin Boudnik added a comment -

        Simple 'svn move' breaks tests compilation:

        compile-fault-inject:
             [echo] Start weaving aspects in place
             [iajc] error at public class TestRename {
             [iajc]              ^^^^^^^^^
             [iajc] /Users/cos/work/H0.22/hdfs/src/test/aop/org/apache/hadoop/fs/TestFiRename.java:50:0::0 The public type TestRename must be defined in its own file
             [iajc] MessageHolder:  (215 info)  (1 error) 
             [iajc] [error   0]: error at public class TestRename {
             [iajc]              ^^^^^^^^^
             [iajc] /Users/cos/work/H0.22/hdfs/src/test/aop/org/apache/hadoop/fs/TestFiRename.java:50:0::0 The public type TestRename must be defined in its own file
        

        class has to be renamed as well.

        Suresh Srinivas added a comment -

        I have attached a new patch renaming the class to match the file name. Thanks Cos.

        Konstantin Boudnik added a comment -

        Have ran all fault-injection tests: the problem is gone.
        +1 on the patch.

        Suresh Srinivas added a comment -

        Committed the new patch without waiting for Hudson. Hudson currently cannot run test-patch due to build issue introduced by the previous commit from this jira.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12436617/hdfs-913.patch
        against trunk revision 911744.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 6 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/241/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/241/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/241/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/241/console

        This message is automatically generated.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #197 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/197/)

        Hudson added a comment -

        Integrated in Hdfs-Patch-h2.grid.sp2.yahoo.net #146 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/146/)

        Hudson added a comment -

        Integrated in Hdfs-Patch-h5.grid.sp2.yahoo.net #302 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/302/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #275 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/275/)


          People

          • Assignee:
            Suresh Srinivas
            Reporter:
            Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development