Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8807

dfs.datanode.data.dir does not handle spaces between storageType and URI correctly

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: datanode
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      if you add a space between the storage type and file URI then datanodes fail during startup.
      Here is an example of "mis-configration" that leads to datanode failure.

      <property>
          <name>dfs.datanode.data.dir</name>
          <value>
            [DISK] file://tmp/hadoop-aengineer/disk1/dfs/data
          </value>
        </property>
      

      Here is the "fixed" version. Please note the lack of space between [DISK] and file URI

      <property>
          <name>dfs.datanode.data.dir</name>
          <value>
            [DISK]file://tmp/hadoop-aengineer/disk1/dfs/data
          </value>
        </property>
      

      we fail with a parsing error, here is the info from the datanode logs.

      2015-07-22 13:34:36,812 FATAL org.apache.hadoop.hdfs.server.datanode.DataNode: Exception in secureMain
      java.lang.IllegalArgumentException: java.net.URISyntaxException: Illegal character in scheme name at index 0:  file://tmp/hadoop-aengineer/disk1/dfs/data
              at org.apache.hadoop.fs.Path.initialize(Path.java:204)
              at org.apache.hadoop.fs.Path.<init>(Path.java:170)
              at org.apache.hadoop.hdfs.server.datanode.StorageLocation.parse(StorageLocation.java:97)
              at org.apache.hadoop.hdfs.server.datanode.DataNode.getStorageLocations(DataNode.java:2314)
              at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:2298)
              at org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:2349)
              at org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:2529)
              at org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:2553)
      Caused by: java.net.URISyntaxException: Illegal character in scheme name at index 0:  file://tmp/hadoop-aengineer/disk1/dfs/data
              at java.net.URI$Parser.fail(URI.java:2829)
              at java.net.URI$Parser.checkChars(URI.java:3002)
              at java.net.URI$Parser.checkChar(URI.java:3012)
              at java.net.URI$Parser.parse(URI.java:3028)
              at java.net.URI.<init>(URI.java:753)
              at org.apache.hadoop.fs.Path.initialize(Path.java:201)
              ... 7 more
      
      1. HDFS-8807.001.patch
        5 kB
        Anu Engineer
      2. HDFS-8807.002.patch
        4 kB
        Anu Engineer

        Activity

        aw Allen Wittenauer added a comment -

        Technically, throwing an error on the space is correct; spaces aren't safe in URIs and should be encoded.

        anu Anu Engineer added a comment -

        Allen Wittenauer agree, but this is not part of the URI. This is just a white space before URI. I ran into this myself, and it is a trivial patch to fix. The [StorageType][URI] notation makes it tempting for users to put a space between the type and URI.

        aw Allen Wittenauer added a comment -

        Fundamentally, this is the problem:

        The [StorageType][URI] notation

        If we had a DTD for the XML, what would it look like? We've basically built an untestable monster. If my app is not Hadoop and want to parse or build this file, how is it supposed to be coded?

        anu Anu Engineer added a comment -

        *Added trim() to remove white space from the URI.

        • Added test cases to verify that we are able to handle spaces between [StorageType] and URI
        anu Anu Engineer added a comment -

        If we had a DTD for the XML, what would it look like? We've basically built an untestable monster.

        I agree that we have a pretty complex config. I am not even sure if all the assumptions we have about configs can be encoded in a DTD, especially things like cross-key value dependencies.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 20m 48s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 40s There were no new javac warning messages.
        +1 javadoc 9m 46s There were no new javadoc warning messages.
        +1 release audit 0m 24s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 1m 21s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 25s mvn install still works.
        +1 eclipse:eclipse 0m 34s The patch built with eclipse:eclipse.
        +1 findbugs 2m 36s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 3m 9s Pre-build of native portion
        -1 hdfs tests 160m 32s Tests failed in hadoop-hdfs.
            208m 19s  



        Reason Tests
        Failed unit tests hadoop.hdfs.server.namenode.ha.TestHAStateTransitions
          hadoop.hdfs.server.datanode.TestDataNodeMetrics
          hadoop.hdfs.web.TestWebHdfsTimeouts
          hadoop.hdfs.TestDistributedFileSystem



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12746654/HDFS-8807.001.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 06e5dd2
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11792/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11792/testReport/
        Java 1.7.0_55
        uname Linux asf903.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11792/console

        This message was automatically generated.

        anu Anu Engineer added a comment -

        Failure does not seem to be related to this patch. These tests are passing with this patch on my local machine.

        szetszwo Tsz Wo Nicholas Sze added a comment -

        +1 patch looks good.

        szetszwo Tsz Wo Nicholas Sze added a comment -
        - *     http://www.apache.org/licenses/LICENSE-2.0
        + * http://www.apache.org/licenses/LICENSE-2.0
        

        Indeed, we should not change the license header. Please revert it.

        anu Anu Engineer added a comment -

        sure thing, looks like my editor auto fixed the spaces in license header. I will fix it and post a new patch.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 25s trunk passed
        +1 compile 0m 38s trunk passed with JDK v1.8.0_66
        +1 compile 0m 45s trunk passed with JDK v1.7.0_85
        +1 checkstyle 0m 16s trunk passed
        +1 mvnsite 0m 53s trunk passed
        +1 mvneclipse 0m 14s trunk passed
        +1 findbugs 1m 54s trunk passed
        +1 javadoc 1m 7s trunk passed with JDK v1.8.0_66
        +1 javadoc 1m 50s trunk passed with JDK v1.7.0_85
        +1 mvninstall 0m 49s the patch passed
        +1 compile 0m 40s the patch passed with JDK v1.8.0_66
        +1 javac 0m 40s the patch passed
        +1 compile 0m 42s the patch passed with JDK v1.7.0_85
        +1 javac 0m 42s the patch passed
        +1 checkstyle 0m 15s the patch passed
        +1 mvnsite 0m 52s the patch passed
        +1 mvneclipse 0m 14s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 2m 1s the patch passed
        +1 javadoc 1m 7s the patch passed with JDK v1.8.0_66
        +1 javadoc 1m 47s the patch passed with JDK v1.7.0_85
        -1 unit 52m 30s hadoop-hdfs in the patch failed with JDK v1.8.0_66.
        -1 unit 50m 35s hadoop-hdfs in the patch failed with JDK v1.7.0_85.
        -1 asflicense 0m 21s Patch generated 58 ASF License warnings.
        129m 31s



        Reason Tests
        JDK v1.8.0_66 Failed junit tests hadoop.hdfs.server.balancer.TestBalancerWithMultipleNameNodes
          hadoop.hdfs.server.namenode.TestFsck
          hadoop.hdfs.server.blockmanagement.TestNodeCount
          hadoop.hdfs.TestRecoverStripedFile
          hadoop.hdfs.TestErasureCodingPolicies
          hadoop.hdfs.TestDFSStripedOutputStreamWithFailure010
          hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
          hadoop.security.TestPermission
          hadoop.hdfs.TestWriteReadStripedFile
        JDK v1.7.0_85 Failed junit tests hadoop.hdfs.server.blockmanagement.TestPendingInvalidateBlock
          hadoop.hdfs.TestDatanodeDeath
          hadoop.security.TestPermission



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:0ca8df7
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12746654/HDFS-8807.001.patch
        JIRA Issue HDFS-8807
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e0221b9c81d8 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / db4cab2
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HDFS-Build/13643/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt
        unit https://builds.apache.org/job/PreCommit-HDFS-Build/13643/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85.txt
        unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13643/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_66.txt https://builds.apache.org/job/PreCommit-HDFS-Build/13643/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_85.txt
        JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13643/testReport/
        asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13643/artifact/patchprocess/patch-asflicense-problems.txt
        modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
        Max memory used 76MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13643/console

        This message was automatically generated.

        anu Anu Engineer added a comment -

        Fix removing space from lic. header

        szetszwo Tsz Wo Nicholas Sze added a comment -

        I have committed this. Thanks, Anu!

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8882 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8882/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2660 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2660/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #719 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/719/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #1451 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1451/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #729 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/729/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2577 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2577/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #640 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/640/)
        HDFS-8807. dfs.datanode.data.dir does not handle spaces between (szetszwo: rev 78ec38b2ede8bdf3874b2ae051af9580007a9ba1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataDirs.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/StorageLocation.java

          People

          • Assignee:
            anu Anu Engineer
            Reporter:
            anu Anu Engineer
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development