Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8596

TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.7.1
    • Fix Version/s: 2.8.0, 2.7.1, 3.0.0-alpha1
    • Component/s: datanode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      After HDFS-8572, some tests failed in branch-2 as below:

      Running org.apache.hadoop.hdfs.TestDistributedFileSystem
      Tests run: 17, Failures: 0, Errors: 3, Skipped: 0, Time elapsed: 44.302 sec <<< FAILURE! - in org.apache.hadoop.hdfs.TestDistributedFileSystem
      testAllWithDualPort(org.apache.hadoop.hdfs.TestDistributedFileSystem)  Time elapsed: 7.985 sec  <<< ERROR!
      java.io.IOException: Server returned HTTP response code: 500 for URL: http://127.0.0.1:43950/getFileChecksum/filechecksum/foo0?ugi=yzhangx&nnaddr=localhost:57316
              at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1625)
              at org.apache.hadoop.hdfs.web.HftpFileSystem$ChecksumParser.getFileChecksum(HftpFileSystem.java:528)
              at org.apache.hadoop.hdfs.web.HftpFileSystem$ChecksumParser.access$200(HftpFileSystem.java:504)
              at org.apache.hadoop.hdfs.web.HftpFileSystem.getFileChecksum(HftpFileSystem.java:545)
              at org.apache.hadoop.hdfs.TestDistributedFileSystem.testFileChecksum(TestDistributedFileSystem.java:592)
              at org.apache.hadoop.hdfs.TestDistributedFileSystem.testAllWithDualPort(TestDistributedFileSystem.java:683)
      

      I found that the cause is the wrong setting of "datanode" attribute in ServletContext introduced by this change.

        Issue Links

          Activity

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2175 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2175/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #227 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/227/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2157 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2157/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #218 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/218/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #959 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/959/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #229 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/229/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          yzhangal Yongjun Zhang added a comment -

          Thanks Jitendra Nath Pandey and Brahma Reddy Battula a lot for the review, I committed to trunk, branch-2, branch-2.7.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8015 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8015/)
          HDFS-8596. TestDistributedFileSystem et al tests are broken in branch-2 due to incorrect setting of "datanode" attribute. Contributed by Yongjun Zhang. (yzhang: rev b0dc291961410b6ac2b275cdcff4b95d75727e8d)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/web/DatanodeHttpServer.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 pre-patch 15m 6s Findbugs (version ) appears to be broken on trunk.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 28s There were no new javac warning messages.
          +1 javadoc 9m 33s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 50s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 35s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 3m 13s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 3m 13s Pre-build of native portion
          +1 hdfs tests 161m 21s Tests passed in hadoop-hdfs.
              203m 16s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12739474/HDFS-8596.001.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / b8341f1
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11343/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11343/testReport/
          Java 1.7.0_55
          uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11343/console

          This message was automatically generated.

          brahmareddy Brahma Reddy Battula added a comment -

          Nice catch!! +1 ( nonbinding)

          jnp Jitendra Nath Pandey added a comment -

          +1, thanks for catching this Yongjun Zhang

          yzhangal Yongjun Zhang added a comment -

          We really need some periodic branch-2 jenkins test, probably even a pre-commit test for branch-2.


            People

            • Assignee:
              yzhangal Yongjun Zhang
              Reporter:
              yzhangal Yongjun Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development