Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8255

Rename getBlockReplication to getPreferredBlockReplication

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.8.0
    • 2.8.0, 3.0.0-alpha1
    • None
    • Reviewed

    Description

      We should rename BlockCollection#getBlockReplication to getPreferredBlockStorageNum for 2 reasons:

      1. Currently, this method actually returns the preferred block replication factor instead of the actual number of replicas. The current name is a little ambiguous. getPreferredBlockStorageNum is also consistent with getPreferredBlockSize
      2. With the erasure coding feature, the name doesn't apply to striped blocks.

      Attachments

        1. HDFS-8255.000.patch
          28 kB
          Zhe Zhang
        2. HDFS-8255.001.patch
          28 kB
          Zhe Zhang
        3. HDFS-8255.002.patch
          29 kB
          Zhe Zhang

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            zhz Zhe Zhang
            zhz Zhe Zhang
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment