We should rename BlockCollection#getBlockReplication to getPreferredBlockStorageNum for 2 reasons:
- Currently, this method actually returns the preferred block replication factor instead of the actual number of replicas. The current name is a little ambiguous. getPreferredBlockStorageNum is also consistent with getPreferredBlockSize
- With the erasure coding feature, the name doesn't apply to striped blocks.