Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8076

Code cleanup for DFSInputStream: use offset instead of LocatedBlock when possible

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None

      Description

      This JIRA aims to refactor the signatures fetchBlockByteRange and actualGetFromOneDataNode. Instead of taking a LocatedBlock, I think they should just take the starting offset of that block, since they'll later call getBlockAt to refresh the location anyway. I think we should make it clear so the callers are not surprised if the finally used LocatedBlock is not the one they passed in.

        Attachments

          Activity

            People

            • Assignee:
              zhz Zhe Zhang
              Reporter:
              zhz Zhe Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: