Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-7743

Code cleanup of BlockInfo and rename BlockInfo to BlockInfoContiguous

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7.0
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      In the work of erasure coding (HDFS-7285), we plan to extend the class BlockInfo to two subclasses: BlockReplicationInfo and BlockGroupInfo (HDFS-7716). To ease the HDFS-EC branch syncing with trunk, this jira plans to rename the current BlockInfo to BlockReplicationInfo in trunk. In the meanwhile, we can also use this chance to do some minor code cleanup.

        Attachments

        1. HDFS-7743.000.patch
          214 kB
          Jing Zhao
        2. HDFS-7743.001.patch
          213 kB
          Jing Zhao
        3. HDFS-7743.002.patch
          214 kB
          Jing Zhao

          Issue Links

            Activity

              People

              • Assignee:
                jingzhao Jing Zhao
                Reporter:
                jingzhao Jing Zhao
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: