Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-6348

SecondaryNameNode not terminating properly on runtime exceptions

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: namenode
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Secondary Namenode is not exiting when there is RuntimeException occurred during startup.

      Say I configured wrong configuration, due to that validation failed and thrown RuntimeException as shown below. But when I check the environment SecondaryNamenode process is alive. When analysed, RMI Thread is still alive, since it is not a daemon thread JVM is nit exiting.

      I'm attaching threaddump to this JIRA for more details about the thread.

      java.lang.RuntimeException: java.lang.RuntimeException: java.lang.ClassNotFoundException: Class com.huawei.hadoop.hdfs.server.blockmanagement.MyBlockPlacementPolicy not found
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:1900)
      	at org.apache.hadoop.hdfs.server.blockmanagement.BlockPlacementPolicy.getInstance(BlockPlacementPolicy.java:199)
      	at org.apache.hadoop.hdfs.server.blockmanagement.BlockManager.<init>(BlockManager.java:256)
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.<init>(FSNamesystem.java:635)
      	at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.initialize(SecondaryNameNode.java:260)
      	at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.<init>(SecondaryNameNode.java:205)
      	at org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.main(SecondaryNameNode.java:695)
      Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: Class com.huawei.hadoop.hdfs.server.blockmanagement.MyBlockPlacementPolicy not found
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:1868)
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:1892)
      	... 6 more
      Caused by: java.lang.ClassNotFoundException: Class com.huawei.hadoop.hdfs.server.blockmanagement.MyBlockPlacementPolicy not found
      	at org.apache.hadoop.conf.Configuration.getClassByName(Configuration.java:1774)
      	at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:1866)
      	... 7 more
      2014-05-07 14:27:04,666 INFO org.apache.hadoop.hdfs.server.namenode.FSNamesystem: Stopping services started for active state
      2014-05-07 14:27:04,666 INFO org.apache.hadoop.hdfs.server.namenode.FSNamesystem: Stopping services started for standby state
      2014-05-07 14:31:04,926 INFO org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode: STARTUP_MSG: 
      
      1. HDFS-6348.patch
        2 kB
        Rakesh R
      2. HDFS-6348.patch
        2 kB
        Rakesh R
      3. HDFS-6348-003.patch
        2 kB
        Rakesh R
      4. HDFS-6348-004.patch
        4 kB
        Rakesh R
      5. secondaryNN_threaddump_after_exit.log
        8 kB
        Rakesh R

        Activity

        rakeshr Rakesh R added a comment -

        Attaching a patch where I've improved exception block and calling terminate(). Since it involves System.exit(), I couldn't manage to add a testcase. Appreciate any help in reviewing the patch. Thanks!

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12698124/HDFS-6348.patch
        against trunk revision b379972.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.server.balancer.TestBalancer
        org.apache.hadoop.hdfs.TestDecommission

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9541//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9541//console

        This message is automatically generated.

        rakeshr Rakesh R added a comment -

        Appreciate any help in reviewing the scenario and the attached patch. Thanks!

        rakeshr Rakesh R added a comment -

        Attached re-based(in latest trunk) patch to get the jenkins report.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 35s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 javac 7m 28s There were no new javac warning messages.
        +1 javadoc 9m 35s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 2m 21s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 36s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 3m 5s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 native 3m 13s Pre-build of native portion
        +1 hdfs tests 183m 49s Tests passed in hadoop-hdfs.
            226m 47s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12730177/HDFS-6348-003.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / bb9ddef
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10781/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10781/testReport/
        Java 1.7.0_55
        uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10781/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 38s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 javac 7m 30s There were no new javac warning messages.
        +1 javadoc 9m 36s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 0m 38s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 38s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 3m 4s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 native 3m 12s Pre-build of native portion
        +1 hdfs tests 177m 57s Tests passed in hadoop-hdfs.
            219m 24s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12730178/HDFS-6348-003.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / bb9ddef
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10782/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10782/testReport/
        Java 1.7.0_55
        uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10782/console

        This message was automatically generated.

        rakeshr Rakesh R added a comment -

        Since it involves System.exit(), I couldn't manage to add a testcase. Appreciate reviews. Thanks!

        vinayrpet Vinayakumar B added a comment -

        Since it involves System.exit(), I couldn't manage to add a testcase.

        In MiniDFSCluster tests, System.exit() is disabled. Check ExitUtil.

        Secondary namenode - RMI Thread prevents JVM from exiting after main() completes

        By default, hadoop doesnt ship with jmx enabled. Title and description are little confusing when compared with the patch fix. It could be made simple like 'SecondaryNameNode not terminating properly on runtime exceptions'

        Coming to patch, instead of adding one more try-catch block, can handle throwable instead of IOException in existing block itself?

        rakeshr Rakesh R added a comment -

        Vinayakumar B Thank you for the reviews. I'll do the suggested changes and try to add unit test case.

        rakeshr Rakesh R added a comment -

        Attached patch addressing the comments. I've tried adding unit test case.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 15m 7s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 41s There were no new javac warning messages.
        +1 javadoc 9m 55s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 0m 50s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 39s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 3m 10s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 native 3m 19s Pre-build of native portion
        -1 hdfs tests 167m 43s Tests failed in hadoop-hdfs.
            210m 21s  



        Reason Tests
        Failed unit tests hadoop.cli.TestCryptoAdminCLI
          hadoop.cli.TestAclCLI
          hadoop.tracing.TestTracing
          hadoop.tools.TestJMXGet
          hadoop.tracing.TestTracingShortCircuitLocalRead
          hadoop.cli.TestXAttrCLI
          hadoop.cli.TestHDFSCLI



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12733091/HDFS-6348-004.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 1ea9014
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10999/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10999/testReport/
        Java 1.7.0_55
        uname Linux asf904.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10999/console

        This message was automatically generated.

        vinayrpet Vinayakumar B added a comment -

        Patch LGTM +1,
        failures are unrelated.
        Going to commit shortly

        vinayrpet Vinayakumar B added a comment -

        Committed to trunk and branch-2.
        Thanks Rakesh R

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #7858 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7858/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        rakeshr Rakesh R added a comment -

        Thank you Vinayakumar B for the reviews and committing the patch.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #932 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/932/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #201 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/201/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2130 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2130/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #190 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/190/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Mapreduce-trunk-Java8 #200 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/200/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2148 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2148/)
        HDFS-6348. SecondaryNameNode not terminating properly on runtime exceptions (Contributed by Rakesh R) (vinayakumarb: rev 93972a332a9fc6390447fc5fc9785c98fb4c3344)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStartup.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode.java

          People

          • Assignee:
            rakeshr Rakesh R
            Reporter:
            rakeshr Rakesh R
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development