Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-5943

'dfs.namenode.https-address.ns1' property is not used in federation setup

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.4.0
    • None
    • None
    • Reviewed

    Description

      When federation is ON and two name nodes exist in Cluster, dfs.namenode.https-address property is not being respected when dfs.http.policy= HTTPS_ONLY

      Scenario:
      Pre condition:
      Cluster with one namenode is running. The dfs.namenode.https-address is set to 50701. Namenode UI is accessible at https://NN:50701

      Steps followed:
      1) Enable Federation and start new NN.
      2) Set https addresses for both NNs.
      <property><name>dfs.federation.nameservices</name><value>ns1,ns2</value></property>
      <property><name>dfs.namenode.https-address.ns2</name><value>host2:50701</value></property>
      <property><name>dfs.namenode.https-address.ns1</name><value>host1:50701</value></property>
      3) restart Existing and New namenodes.

      Expected behavior:
      Both the name nodes are expected to be accessed on 50701 port. Instead both the Name nodes start with 50470 port.
      https://NN:50470

      Attachments

        1. HDFS-5943.patch
          5 kB
          Suresh Srinivas
        2. HDFS-5943.1.patch
          5 kB
          Suresh Srinivas

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            sureshms Suresh Srinivas
            yeshavora Yesha Vora
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment