I'm not sure if we want to rename these. For example, if we rename dfs.namenode.path.based.cache.refresh.interval.ms to dfs.namenode.cache.refresh.interval.ms, it starts to sound awfully generic.
The rename that removed "PathBased" from a bunch of class names was just a matter of necessity-- the names were getting too cumbersome, and we didn't think there would be conflicts. With the config keys, a long name is not such a big problem since we only use them once or twice throughout the code. And it does help to disambiguate them from all the other cache configurations we have (and there are many)