Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-4949 Centralized cache management in HDFS
  3. HDFS-5473

Consistent naming of user-visible caching classes and methods

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 2.3.0
    • Component/s: datanode, namenode
    • Labels:
      None

      Description

      It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has *CachePool methods take a CachePoolInfo and *PathBasedCacheDirective methods that thake a PathBasedCacheDirective. We should consider renaming CachePoolInfo to CachePool for consistency.

        Attachments

        1. HDFS-5473.002.patch
          214 kB
          Colin McCabe
        2. HDFS-5473.003.patch
          220 kB
          Colin McCabe

          Activity

            People

            • Assignee:
              cmccabe Colin McCabe
              Reporter:
              andrew.wang Andrew Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: