Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: documentation
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The framework documentation and aspects development guide is needed to be developed in Forrest xml and then checked under src/docs/src/documentation/content/xdocs

      1. HDFS-498.patch
        16 kB
        Konstantin Boudnik
      2. FI-framework.odg
        79 kB
        Konstantin Boudnik
      3. FI-framework.png
        232 kB
        Konstantin Boudnik
      4. faultinject_framework.pdf
        24 kB
        Konstantin Boudnik
      5. HDFS-498.patch
        16 kB
        Konstantin Boudnik
      6. HDFS-498.patch
        16 kB
        Konstantin Boudnik
      7. HDFS-498.patch
        16 kB
        Konstantin Boudnik
      8. faultinject_framework.pdf
        23 kB
        Konstantin Boudnik
      9. FI-framework.gif
        30 kB
        Tsz Wo Nicholas Sze
      10. faultinject_framework.pdf
        77 kB
        Tsz Wo Nicholas Sze
      11. HDFS-498.patch
        16 kB
        Konstantin Boudnik
      12. faultinject_framework.pdf
        77 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Konstantin Boudnik added a comment -

          Files include patch for the issue and two binary files: ODG & PNG formats of FI framework architecture

          Konstantin Boudnik added a comment -

          Patch adds new aspects development and Fault Injection Framework HOWTO guides.

          I propose to add this document to the Hadoop's documentation structure as follows:

          HDFS
          |
          ...
          |_Testing
             |_Fault Injection
          
          Konstantin Boudnik added a comment -

          The pdf version of Forrest generated documentation

          Konstantin Boudnik added a comment -

          Some lines length has been reduced for better PDF production

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12414757/HDFS-498.patch
          against trunk revision 799146.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/33/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/33/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/33/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/33/console

          This message is automatically generated.

          Konstantin Boudnik added a comment -

          Reviewed by Nigel.
          Some typos are corrected by Corinne.

          Seems to be good to go.

          Corinne Chandel added a comment -

          +1 documentation. The documentation looks good.

          Konstantin Boudnik added a comment -

          Has submitted wrong patch previously.

          Konstantin Boudnik added a comment -

          Extra <meta> symbols are removed from the xml file, cause they are appear in the resulting PDF file

          Konstantin Boudnik added a comment -

          Updated version of resulting PDF file

          Tsz Wo Nicholas Sze added a comment -

          The diagram (FI-framework.png) is missing in the pdf file. Could you check it, Cos?

          Konstantin Boudnik added a comment -

          Yes, I've noticed that too. I've tried to find out what's wrong with it and failed... Let me dig deeper into this issue. if there are any experts on Forrest here I'd appreciate the help!

          Konstantin Boudnik added a comment -

          I believe we might have to leave with this issue (see http://issues.apache.org/jira/browse/FOR-413)
          The problem is: PNG files are quietly ignored; a GIF file is causing runtime error in the forrest environment at the attempt to generate a PDF file.

          I'd suggest to go with the absence of the picture in PDF file unless someone knows a workaround for the problem.

          Tsz Wo Nicholas Sze added a comment -
          +      <figure src="images/FI-framework.png" alt="Framework's components layout"
          +              width="550" height="751"/>
          

          Since there is a resize in the figure element, we could first resize the diagram and save it as FI-framework.gif. The result gif is small enough that forrest could generate faultinject_framework.pdf. Of course, we have to change the figure element as below.

          +      <figure src="images/FI-framework.gif" alt="Framework's components layout" />
          
          Tsz Wo Nicholas Sze added a comment -

          Although the FI-framework.gif thumbnail generated by JIRA in "Image Attachments" seems not working - it becomes all black, the actual file seems fine. Click the link "FI-framework.gif" to see the original file.

          Konstantin Boudnik added a comment -

          I can confirm that the .gif file uploaded by Nicholas does the trick.
          I've even realized why my experiment with gif files weren't successful - I had to actually RESTART Forrest runtime to make PDF generation works

          New version of the patch (without resizing of the image) and final PDF file are attached.

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Cos!

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #40 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/40/)
          . Add development guide and documentation for the fault injection framework. Contributed by Konstantin Boudnik


            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development