Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-490

eliminate the usage of FileSystem.create( ) depracated by Hadoop-5438

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Issue Links

        Activity

        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #34 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/34/)
        . Eliminate the deprecated warnings introduced by H-5438. Contributed by He Yongqiang

        Tsz Wo Nicholas Sze made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Tsz Wo Nicholas Sze added a comment -

        I have committed this. Thanks, Yongqiang!

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12413549/hdfs-490-2009-07-15.patch
        against trunk revision 798233.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 9 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/30/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/30/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/30/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/30/console

        This message is automatically generated.

        Tsz Wo Nicholas Sze made changes -
        Link This issue is duplicated by HDFS-499 [ HDFS-499 ]
        Tsz Wo Nicholas Sze made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Tsz Wo Nicholas Sze added a comment -

        The common jar file was updated recently. Re-submitting the patch.

        Tsz Wo Nicholas Sze made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Affects Version/s 0.21.0 [ 12314046 ]
        Fix Version/s 0.21.0 [ 12314046 ]
        He Yongqiang added a comment -

        not sure why it fails.
        But when i remove the hadoop-core-.jar from build path and add hadoop-core project as a dependent project of hadoop-hdfs. The testFSInputChecker passed. So maybe the problem is caused by the out of date hadoop-core-.jar file.

        Tsz Wo Nicholas Sze added a comment -

        However, TestFSInputChecker.testFSInputChecker failed. It seems related.

        Tsz Wo Nicholas Sze made changes -
        Hadoop Flags [Reviewed]
        Assignee He Yongqiang [ he yongqiang ]
        Component/s test [ 12312916 ]
        Tsz Wo Nicholas Sze added a comment -

        +1 patch looks good.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12413549/hdfs-490-2009-07-15.patch
        against trunk revision 794054.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 9 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/22/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/22/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/22/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/22/console

        This message is automatically generated.

        He Yongqiang made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Tsz Wo Nicholas Sze made changes -
        Link This issue is related to HADOOP-6138 [ HADOOP-6138 ]
        He Yongqiang made changes -
        Field Original Value New Value
        Attachment hdfs-490-2009-07-15.patch [ 12413549 ]
        He Yongqiang created issue -

          People

          • Assignee:
            He Yongqiang
            Reporter:
            He Yongqiang
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development