Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-4509

Provide a way to ask Balancer to exclude certain DataNodes in its computation and/or work.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: balancer
    • Labels:
      None

      Description

      This comes particularly useful in clusters that have a split between DNs used for regular purpose and DNs used for HBase RSes specifically. By asking the balancer to exclude the DNs that RSes run on, its possible to avoid impacting HBase's local reads performance, and the balancing of these nodes can be deferred to a later time.

      An alternate, and perhaps simpler approach would be to make the Balancer file-aware and ask it to skip a specific directory's file's blocks (i.e. that of /hbase for example).

        Issue Links

          Activity

          Harsh J created issue -
          Harsh J added a comment -

          Another general solution is to run HBase itself on a separate, federated NS, and only balance the non HBase NS, which is supported today.

          Harsh J added a comment -

          Dupe of HDFS-4420.

          Harsh J made changes -
          Field Original Value New Value
          Link This issue duplicates HDFS-4420 [ HDFS-4420 ]
          Harsh J made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Harsh J
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development