Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-4180

TestFileCreation fails in branch-1 but not branch-1.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Testcase: testFileCreation took 3.419 sec
      	Caused an ERROR
      java.io.IOException: Cannot create /test_dir; already exists as a directory
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFileInternal(FSNamesystem.java:1374)
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFile(FSNamesystem.java:1334)
      	...
      	at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1387)
      
      org.apache.hadoop.ipc.RemoteException: java.io.IOException: Cannot create /test_dir; already exists as a directory
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFileInternal(FSNamesystem.java:1374)
      	...
      	at org.apache.hadoop.fs.FileSystem.create(FileSystem.java:443)
      	at org.apache.hadoop.hdfs.TestFileCreation.checkFileCreation(TestFileCreation.java:249)
      	at org.apache.hadoop.hdfs.TestFileCreation.testFileCreation(TestFileCreation.java:179)
      

        Issue Links

          Activity

          Matt Foley added a comment -

          Closed upon release of Hadoop 1.2.0.

          Matt Foley added a comment -

          Pardon the above thrash. This problem only happens in 1.2.0 because it was caused by HDFS-4122 which is only committed to branch-1.

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Jing!

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good. The patch works well.

          Jing Zhao added a comment -

          The error is caused by the inconsistency between real exception msg and expected exception msg. A simple change can fix the error and the local TestFileCreation now passed.


            People

            • Assignee:
              Jing Zhao
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development