Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3715

Fix TestFileCreation#testFileCreationNamenodeRestart

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestFileCreation#testFileCreationNamenodeRestart is ignored due to the following. We should (a) modify this test to test the current expected behavior for leases on restart and (b) file any jiras for necessary fixes to close the gap between current and desired behavior.

        /**
         * Test that file leases are persisted across namenode restarts.
         * This test is currently not triggered because more HDFS work is 
         * is needed to handle persistent leases.
         */
        @Ignore
        @Test
        public void xxxtestFileCreationNamenodeRestart() throws IOException {
      
      1. hdfs-3715-2.patch
        3 kB
        Andrew Wang
      2. hdfs-3715-1.patch
        3 kB
        Andrew Wang

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1175 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1175/)
        HDFS-3715. Fix TestFileCreation#testFileCreationNamenodeRestart. Contributed by Andrew Whang (Revision 1376689)

        Result = FAILURE
        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376689
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileCreation.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1144 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1144/)
        HDFS-3715. Fix TestFileCreation#testFileCreationNamenodeRestart. Contributed by Andrew Whang (Revision 1376689)

        Result = FAILURE
        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376689
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileCreation.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2658 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2658/)
        HDFS-3715. Fix TestFileCreation#testFileCreationNamenodeRestart. Contributed by Andrew Whang (Revision 1376689)

        Result = FAILURE
        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376689
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileCreation.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2694 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2694/)
        HDFS-3715. Fix TestFileCreation#testFileCreationNamenodeRestart. Contributed by Andrew Whang (Revision 1376689)

        Result = FAILURE
        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376689
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileCreation.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2630 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2630/)
        HDFS-3715. Fix TestFileCreation#testFileCreationNamenodeRestart. Contributed by Andrew Whang (Revision 1376689)

        Result = SUCCESS
        eli : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1376689
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileCreation.java
        Eli Collins added a comment -

        I've committed this and merged to branch-2. Thanks Andrew!

        Eli Collins added a comment -

        Test failure is HDFS-3664. Findbugs is HDFS-3850.

        Eli Collins added a comment -

        I agree the failure seems unrelated. I ran locally as well, will commit when jenkins comes back.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12542165/hdfs-3715-2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        -1 findbugs. The patch appears to introduce 2 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.TestPersistBlocks

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3079//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/3079//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3079//console

        This message is automatically generated.

        Andrew Wang added a comment -

        Rebase on trunk, patch was stale.

        Andrew Wang added a comment -

        This test failure could be related to HDFS-3658, the logs look like the same problem even though the assert failure is a bit different.

        Anyway, I ran this test locally and it worked. I believe unrelated.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12539124/hdfs-3715-1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.TestDFSClientRetries

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2950//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2950//console

        This message is automatically generated.

        Eli Collins added a comment -

        +1 pending jenkins

        Andrew Wang added a comment -

        Turns out this test wasn't really disabled, TestFileCreationNameodeRestart.java was weirdly calling our "disabled" test on the side. Thus I assume that the functionality is still good, since it's been running for a while.

        I deleted this side call and re-enabled the test so it'll run in a more normal fashion.


          People

          • Assignee:
            Andrew Wang
            Reporter:
            Eli Collins
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development