Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-36

Handling of deprecated dfs.info.bindAddress and dfs.info.port

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows XP

      Description

      When checkpointing is triggered in Secondary name node, Secondary name node throws exception while it tries to connect to Namenode's http server in the following two cases:

      1) In hadoop-site.xml, if you put only dfs.http.address but not dfs.info.bindAddress and dfs.info.port (Connection Refused Exception)

      2) In hadoop-site.xml, if you put only dfs.info.bindAddress and dfs.info.port but not dfs.http.address (SecondaryNameNode.getServerAddress line 148 throws exception since newAddrPort is null)

      Temporary Solution: If you put dfs.http.address, dfs.info.bindAddress, and dfs.info.port, then SecondaryNameNode successfully fetches the image and log from Namenode.

        Activity

        Cagdas Gerede created issue -
        Owen O'Malley made changes -
        Field Original Value New Value
        Project Hadoop Common [ 12310240 ] HDFS [ 12310942 ]
        Key HADOOP-3233 HDFS-36
        Affects Version/s 0.16.2 [ 12313051 ]
        Component/s dfs [ 12310710 ]
        Harsh J added a comment -

        Can't reproduce on 1.0+. Setting dfs.http(s).address suffices.

        Harsh J made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Cagdas Gerede
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development