Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3385

ClassCastException when trying to append a file

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.2-alpha
    • Component/s: namenode
    • Labels:
      None
    • Environment:

      HDFS

    • Hadoop Flags:
      Reviewed

      Description

      When I try to append a file I got

      2012-05-08 18:13:40,506 WARN  util.KerberosName (KerberosName.java:<clinit>(87)) - Kerberos krb5 configuration not found, setting default realm to empty
      Exception in thread "main" java.lang.ClassCastException: org.apache.hadoop.hdfs.server.blockmanagement.BlockInfo cannot be cast to org.apache.hadoop.hdfs.server.blockmanagement.BlockInfoUnderConstruction
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.recoverLeaseInternal(FSNamesystem.java:1787)
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFileInternal(FSNamesystem.java:1584)
      	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.appendFile(FSNamesystem.java:1824)
      	at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.append(NameNodeRpcServer.java:425)
              ...
      	at org.apache.hadoop.hdfs.DFSClient.callAppend(DFSClient.java:1150)
      	at org.apache.hadoop.hdfs.DFSClient.append(DFSClient.java:1189)
      	at org.apache.hadoop.hdfs.DFSClient.append(DFSClient.java:1177)
      	at org.apache.hadoop.hdfs.DistributedFileSystem.append(DistributedFileSystem.java:221)
      	at org.apache.hadoop.hdfs.DistributedFileSystem.append(DistributedFileSystem.java:1)
      	at org.apache.hadoop.fs.FileSystem.append(FileSystem.java:981)
      	at org.apache.hadoop.hdfs.server.datanode.DeleteMe.main(DeleteMe.java:26)
      
      1. h3385_20120509.patch
        5 kB
        Tsz Wo Nicholas Sze
      2. h3385_20120508.patch
        0.9 kB
        Tsz Wo Nicholas Sze

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1076 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1076/)
          HDFS-3385. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction, so do not cast it in FSNamesystem.recoverLeaseInternal(..). (Revision 1336976)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1336976
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileAppend.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1040 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1040/)
          HDFS-3385. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction, so do not cast it in FSNamesystem.recoverLeaseInternal(..). (Revision 1336976)

          Result = FAILURE
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1336976
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileAppend.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #2244 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2244/)
          HDFS-3385. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction, so do not cast it in FSNamesystem.recoverLeaseInternal(..). (Revision 1336976)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1336976
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileAppend.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #2227 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2227/)
          HDFS-3385. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction, so do not cast it in FSNamesystem.recoverLeaseInternal(..). (Revision 1336976)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1336976
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileAppend.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #2301 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2301/)
          HDFS-3385. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction, so do not cast it in FSNamesystem.recoverLeaseInternal(..). (Revision 1336976)

          Result = SUCCESS
          szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1336976
          Files :

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/TestFileAppend.java
          Tsz Wo Nicholas Sze added a comment -

          Thanks Suresh for the review.

          I have committed this.

          Suresh Srinivas added a comment -

          +1 for the patch.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12526286/h3385_20120509.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2399//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2399//console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          It turns out that the ClassCastException can be reproduced by the following.

          1. Create a new file with a full block.
          2. Append but not add any data so that the last block remains full and the last block in INodeFileUnderConstruction is a BlockInfo but not BlockInfoUnderConstruction.
          3. Append again.

          h3385_20120509.patch:

          • adds the test above;
          • fixes the indentation.
          Tsz Wo Nicholas Sze added a comment -

          I create HDFS-3394 for removing generic type from INodeFile.getLastBlock(), so that we could keep the patch simple in this issue.

          Tsz Wo Nicholas Sze added a comment -

          Thanks, Brahma. The last block of INodeFileUnderConstruction is not necessarily a BlockInfoUnderConstruction. I will try to add a test.

          We should also remove the generic from INodeFile.getLastBlock(). It is useless as shown here.

          Brahma Reddy Battula added a comment -

          Hi Nichalos..

          I have reproduced same..

          Scenario:
          --------
          write a file
          append a file so that it fails and close the clients
          again try to append the same file we will get ClassCastException.

          I verified your patch..it's fine..

          Brahma Reddy Battula added a comment -

          Hi Nichalos,,thanks for look..

          Actually I didn't get exact scenario to reproduce.

          First, let me try to reproduce this issue and then I'll verify your patch.

          fulltrace when I got

          java.lang.ClassCastException: org.apache.hadoop.hdfs.server.blockmanagement.BlockInfo cannot be cast to org.apache.hadoop.hdfs.server.blockmanagement.BlockInfoUnderConstruction
          	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.recoverLeaseInternal(FSNamesystem.java:1782)
          	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.startFileInternal(FSNamesystem.java:1580)
          	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.appendFile(FSNamesystem.java:1819)
          	at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.append(NameNodeRpcServer.java:416)
          	at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.append(ClientNamenodeProtocolServerSideTranslatorPB.java:217)
          	at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java:42592)
          	at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:417)
          	at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:891)
          	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1661)
          	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1657)
          	at java.security.AccessController.doPrivileged(Native Method)
          	at javax.security.auth.Subject.doAs(Subject.java:396)
          	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1205)
          	at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1655)
          
          	at org.apache.hadoop.ipc.Client.call(Client.java:1159)
          	at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:185)
          	at $Proxy9.append(Unknown Source)
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          	at java.lang.reflect.Method.invoke(Unknown Source)
          	at org.apache.hadoop.io.retry.RetryInvocationHandler.invokeMethod(RetryInvocationHandler.java:165)
          	at org.apache.hadoop.io.retry.RetryInvocationHandler.invoke(RetryInvocationHandler.java:84)
          	at $Proxy9.append(Unknown Source)
          	at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolTranslatorPB.append(ClientNamenodeProtocolTranslatorPB.java:214)
          	at org.apache.hadoop.hdfs.DFSClient.callAppend(DFSClient.java:1178)
          	at org.apache.hadoop.hdfs.DFSClient.append(DFSClient.java:1217)
          	at org.apache.hadoop.hdfs.DFSClient.append(DFSClient.java:1205)
          	at org.apache.hadoop.hdfs.DistributedFileSystem.append(DistributedFileSystem.java:209)
          	at org.apache.hadoop.fs.FileSystem.append(FileSystem.java:973)
          	at com.huawei.isap.test.smartump.hdfs.TestHDFSAPI.appendFile(TestHDFSAPI.java:76)
          	at com.huawei.isap.test.smartump.hdfs.TestHDFSAPI.main(TestHDFSAPI.java:40
          
          Tsz Wo Nicholas Sze added a comment -

          Brahma, thanks for filing the bug. Could you also check if h3385_20120508.patch works for your test case?

          Tsz Wo Nicholas Sze added a comment -

          The line numbers in the stack trace is off. If my guess is correct, the fix could be as simple as the following patch.

          h3385_20120508.patch

          Tsz Wo Nicholas Sze added a comment -

          It seems that ClassCastException is not shown up in the existing unit tests. How to reproduce this exactly? Could you give more details?

          (Let's remove the rpc stack trace in the description.)


            People

            • Assignee:
              Tsz Wo Nicholas Sze
              Reporter:
              Brahma Reddy Battula
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development