I think the current UI is already very clear. We should not make arbitrary changes.
I understand the last point. Consider the patch cancelled until addressed.
But the UI is not clear. Its of no help telling X files and directories in the first place, and then adding blocks to the equation just like that. And then having heap sizes reported right after it to indicate its related to that.
If anything, files # and dirs # should be noted separately, which is also separately computable (but not kept computed afaik). These things may make sense to a HDFS-dev, but has never made enough sense to users, speaking frankly.
What would be a better statement users (and especially, non-java users, i.e. admins) can understand?
And if its not for NN's persistent objects (I wasn't talking java objects, I know each of these is a structure/collection, and on the whole they're still an object) we print that, what do we print it for AND add it to some total?