Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-3276

initializeSharedEdits should have a -nonInteractive flag

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: ha, namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Similar to format and bootstrapStandby, would be nice to have -nonInteractive as an option on initializeSharedEdits

      1. hdfs-3276.txt
        2 kB
        Todd Lipcon

        Activity

        Vinithra Varadharajan created issue -
        Todd Lipcon made changes -
        Field Original Value New Value
        Assignee Todd Lipcon [ tlipcon ]
        Todd Lipcon added a comment -

        Attached patch implements -nonInteractive and -force for initializeSharedEdits. It doesn't include a new test, because the existing tests actually already cover this code path. It's just that it was never hooked up to the command line.

        I tested this manually, verifying that -nonInteractive won't overwrite an already-formatted shared edits, and that -force will do so.

        Todd Lipcon made changes -
        Attachment hdfs-3276.txt [ 12540156 ]
        Todd Lipcon made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Todd Lipcon added a comment -

        Hudson built this here: https://builds.apache.org/job/PreCommit-HDFS-Build/2983/

        but the comment was swallowed during JIRA downtime:

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12540156/hdfs-3276.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        -1 findbugs. The patch appears to introduce 2 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Looking into the new findbugs warnings.

        Todd Lipcon added a comment -

        The two new findbugs warnings are HDFS-3792 - not caused by this patch.

        -1 tests included. The patch doesn't appear to include any new or modified tests.

        There are no new tests since this is just hooking up existing code (which is tested in TestInitializeSharedEdits) to command line flags. I manually tested the command line flags and verified they perform as expected.

        Aaron T. Myers added a comment -

        +1, the patch looks good to me.

        Todd Lipcon added a comment -

        Committed to branch-2 and trunk. Thanks.

        Todd Lipcon made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Fix Version/s 3.0.0 [ 12320356 ]
        Fix Version/s 2.2.0-alpha [ 12322472 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2639 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2639/)
        HDFS-3276. initializeSharedEdits should have a -nonInteractive flag. Contributed by Todd Lipcon. (Revision 1372628)

        Result = SUCCESS
        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1372628
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2574 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2574/)
        HDFS-3276. initializeSharedEdits should have a -nonInteractive flag. Contributed by Todd Lipcon. (Revision 1372628)

        Result = SUCCESS
        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1372628
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2597 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2597/)
        HDFS-3276. initializeSharedEdits should have a -nonInteractive flag. Contributed by Todd Lipcon. (Revision 1372628)

        Result = FAILURE
        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1372628
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1135 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1135/)
        HDFS-3276. initializeSharedEdits should have a -nonInteractive flag. Contributed by Todd Lipcon. (Revision 1372628)

        Result = FAILURE
        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1372628
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1167 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1167/)
        HDFS-3276. initializeSharedEdits should have a -nonInteractive flag. Contributed by Todd Lipcon. (Revision 1372628)

        Result = FAILURE
        todd : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1372628
        Files :

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNode.java
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Allen Wittenauer made changes -
        Fix Version/s 3.0.0 [ 12320356 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        118d 57m 1 Todd Lipcon 10/Aug/12 00:59
        Patch Available Patch Available Resolved Resolved
        3d 21h 27m 1 Todd Lipcon 13/Aug/12 22:27
        Resolved Resolved Closed Closed
        58d 20h 19m 1 Arun C Murthy 11/Oct/12 18:46

          People

          • Assignee:
            Todd Lipcon
            Reporter:
            Vinithra Varadharajan
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development